Messages on Mac automatically adds +44 area code to my text messages

Discussion in 'macOS' started by Melan, Sep 17, 2015.

  1. Melan macrumors regular

    Joined:
    Oct 7, 2007
    #1
    Hi all

    I've looked everywhere on how to change this, I think. When there is no +1 specification, messages on mac automatically prefixes +44 area code (UK) to my message recipients. It's weird because, although Im from England, I bought this Mac in Canada. Any idea what setting this is based on?

    Thanks!
     
  2. XboxMySocks macrumors 68020

    XboxMySocks

    Joined:
    Oct 25, 2009
    #2
    It prefixes it based on your location from what I can tell
     
  3. Melan thread starter macrumors regular

    Joined:
    Oct 7, 2007
    #3
    If so that's weird, I'm in Canada
     
  4. XboxMySocks macrumors 68020

    XboxMySocks

    Joined:
    Oct 25, 2009
  5. Melan thread starter macrumors regular

    Joined:
    Oct 7, 2007
    #5
    No
     
  6. Erdbeertorte macrumors demi-goddess

    Erdbeertorte

    Joined:
    May 20, 2015
    Location:
    Castle Grayskull, Eternia
    #6
    Is your iPhone connected to your Mac (forwarding SMS and/or receiving phone calls with FaceTime)?

    Somewhere in the iPhone settings is a function, I don't know exactly how it's called, maybe dial assist.

    It recognizes by the local area code from what country a number is and puts the international area code in front of it, for example if you are abroad and accidentally dial a number in your home country without the international area code.
    I turned it off, because often it was doing that with local numbers too.

    I just looked everywhere in the settings menu and did not find it. Perhaps it was feature of my old carrier or because I have no data connection at the moment.

    You might look, if there is anything like that in your phone, what maybe your Mac gets from there.
     
  7. chown33 macrumors 604

    Joined:
    Aug 9, 2009
    #7

Share This Page