Messages/SMS issue

Discussion in 'Mac Apps and Mac App Store' started by Achiever, Dec 12, 2015.

  1. Achiever macrumors 6502

    Achiever

    Joined:
    Jan 23, 2008
    #1
    Like many, I use Messages on my iMac, MBP, iPhone and iPad to text non-Apple phone users. Recently I got a new iMac and set up the new machine with backups from my old iMac. I have been using Messages seemingly without issue, but realized a few days ago that I an unable to sent out messages to SMS users and the account on this machine hasn't been syncing the messages I have been sending from my other 3 devices. The other three all send, receive and sync completely. The new iMac ONLY does these things with other Apple users. No SMS sending, receiving or sync.

    When I try to send out a Message on this machine, it immediately says "Not Delivered" with the red exclamation point. When I click on the name of the intended recipient, it lists the phone number along with the following message: XXX-XXX-XXXX is not registered with iMessage. You can turn SMS relay on from your iPhone. I have been to my iPhone and I believe I have this activated. As I said, it works flawlessly on the iPhone, iPad and a MBP. I have turned the machine on and off, closed and re-opened Messages and even logged out and back into the Messages account.

    Anyone ever experienced this? Thoughts on a fix?
     
  2. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #2
    Even if you think it is activated, logout on iMessage, Facetime and iCloud on the MBP, then back in on the MBP, iCloud, FT and iMessage and see if that resolves it.

    In more extreme cases, some have reported success by logging out on all devices, then back in one-by one starting with the iPhone (so other devices see the SMS source), but I've never needed to try that.
     
  3. Eziggy macrumors newbie

    Joined:
    Sep 7, 2010
    #3
    It might make sense to try to remove and re-enable text forwarding for the new iMac from your iPhone.

    Settings -> Messages -> Text Message Forwarding -> uncheck your new iMac then recheck (you should get a confirmation code, etc. on the iMac)

    This happened to me, no matter how many times I would log off and log back in text forwarding wouldn't work for one of my macs.
     
  4. Achiever thread starter macrumors 6502

    Achiever

    Joined:
    Jan 23, 2008
    #4
    THANK YOU! This seems to have done the trick. It had been so long since I set up a Mac I forgot to add it from the phone. Many thanks!
     

Share This Page