Messages to people showing my e-mail not contact name


aarmstrong27

macrumors regular
Jun 20, 2012
148
0
I did a 'reset all settings' last night, and ever since then when I send a message to someone (iMessage) they are receiving it as my e-mail address instead of my regular contact name.

Any fixes for this?

Thanks!
Settings->Messages->Send & Receive->Start New Conversations From:-> select your mobile number.