Messages Typing Lag

Discussion in 'MacBook Pro' started by 3587, Jan 8, 2014.

  1. 3587 macrumors 6502a

    Joined:
    Mar 23, 2008
    #1
    As of late, I've been experiencing typing lag in Messages under Mavericks... Anyone else? Messages seems to crash a lot as well. Very slow. Most other things under Mavericks seems to be fine... A few crashing issues with Mail and that seems to be about it.

    Can I redownload Mavericks and install it on top of the current Mavericks? Would that fix any file issues? Or would I have to do a fresh install of the OS?

    See my specs in signature.
     
  2. Bruno09 macrumors 68020

    Joined:
    Aug 24, 2013
    Location:
    Far from here
    #2
    Hi,

    you should first test Messages in another account to see how it works there.
     
  3. 3587 thread starter macrumors 6502a

    Joined:
    Mar 23, 2008
    #3
    Well, I redownloaded Mavericks from the App Store and installed it over the current Mavericks... I haven't had much time with it since, but everything seems to be a little quicker.

    By doing this, it kept all my same settings, etc. Just entered in my pass code and it was like I didn't do a single thing.

    Why would you see an improvement after doing this?
     
  4. Bill P. macrumors regular

    Bill P.

    Joined:
    Sep 24, 2007
    #4
    Typing lag (often the spinning beach ball) in most programs

    Yes, in TextEdit, Messages, Safari and Mail I'm typing away and all of a sudden no output. I need to wait for the output to appear. Sometimes it is wrong. This is really sapping my productivity.

    Its occurring on my '13 iMac and my MacBook Air.

    Ideas welcome!!

    Bill
     
  5. 3587 thread starter macrumors 6502a

    Joined:
    Mar 23, 2008
    #5
    I turned Contacts off, waited a bit, and turned it back on. For some reason that fixed my lag issue.

     
  6. 3587 thread starter macrumors 6502a

    Joined:
    Mar 23, 2008
  7. Bill P. macrumors regular

    Bill P.

    Joined:
    Sep 24, 2007
    #7
    Oops, missed your note

    Hmm, I'm not sure what you mean by turning contacts off. Kindly explain.

    Thank you!!
     
  8. 3587 thread starter macrumors 6502a

    Joined:
    Mar 23, 2008
    #8
    On your Mac go to System Preferences > iCloud and turn OFF "Contacts". Depending on if you have all your contacts in the cloud, you can choose to keep on Mac or cloud... Restart computer... Then turn Contacts back ON and see if the lag is gone.

    My guess is that the lag is constantly checking Contacts in order to pre-fill some of your typing... If there is a conflict, it might lag while checking.

    Worked for me!
     

Share This Page