Messages won't verify caller ID

Discussion in 'iOS 6' started by morphius111, Sep 20, 2012.

  1. morphius111 macrumors member

    Joined:
    Jul 2, 2010
    #1
    I am trying to add my mobile phone number to messages on my iMac. Once I add it, it goes thru validating and then I get an error that it cannot validate and to remove this email.
    What do I do wrong? How do I add my mobile number to messages on the iMac? All the latest software.
    Can someone please explain in step by step?


    Thanks.
     
  2. blueroom macrumors 603

    blueroom

    Joined:
    Feb 15, 2009
    Location:
    Toronto, Canada
    #2
    Reboot your iPhone on iOS 6 (you're using an iPhone right) and try again. Is it setup properly and working with iMessages?

    You also must be running 10.8.2
     
  3. aarmstrong27 macrumors regular

    Joined:
    Jun 20, 2012
    #3
    Check a few things:
    1. Go to appleid.apple.com, log in, verify your mobile number is entered in the mobile number field, and save.
    2. Make sure you have a device running iOS 6.
    On that device, go to Settings->Messages->Send & Receive. You should already be logged in with your Apple ID here. If not, do so. If you are, click your Apple ID at the top and log out. Then log back in.
    3. You might even need to sign out of Messages on your Mac and then sign back in.

    If all works well, your mobile number should be listed in Messages on your Mac.
    From there, set your Caller ID on both/all devices to your mobile number and you're golden!
     
  4. VSMacOne macrumors 601

    VSMacOne

    Joined:
    Oct 18, 2008
    #4
    Just reset your Network Settings then turn iMessage off and on. Should do it.
     
  5. morphius111 thread starter macrumors member

    Joined:
    Jul 2, 2010
    #5
    Not working

    I cannot figure out the problem.
    Allow me to explain what I do.
    Both iphone and iMac and iPad have the latest software update. So we good with that.

    I go to Messages on my iMac. I open preferences.
    I have an account under iMessage. It is my me.com email. In there I go to:
    YOU CAN REACH FOR MESSAGES AT: and I click the plus sin and add my iPhone number. It tells me Validating and then I get an error that says: Failed to verify email. Remove email.
    My phone number is with Apple here: https://appleid.apple.com
    I am not sure what else to do? Also, how do I add it to the iPad? The same thing. I get errors.
     
  6. morphius111 thread starter macrumors member

    Joined:
    Jul 2, 2010
    #6
    Ipad works fine

    So my iPad and iPhone are fine, but the Messages on my iMac doesn't recognize my phone number.
    I did restart to the computer and turn message off and on few times. Nothing.
     
  7. aarmstrong27 macrumors regular

    Joined:
    Jun 20, 2012
    #7
    You don't ADD your mobile number in preferences on your Mac. You keep getting errors because it only wants email addresses where you are entering your mobile number.

    Is the account you are logged into Messages with on your Mac the same as the Apple ID you are signed into iMessages on your iPhone and iPad?
    If not, therein lies the rub. They have to be the same.

    If so, then do as I said above and LOG OUT of iMessage on your iPhone. Then log back in.
     
  8. morphius111 thread starter macrumors member

    Joined:
    Jul 2, 2010
    #8
    Thanks for the reply, but still nothing. I followed what you said.
     
  9. macfly4 macrumors member

    macfly4

    Joined:
    Apr 15, 2011
    #9
    do you have an older address like .mac or .me? i noticed that one of my computers was using a .mac address and another device a .me.
    not sure if it matters but might cause issues
     
  10. aarmstrong27 macrumors regular

    Joined:
    Jun 20, 2012
    #10
    Did you verify you are using the same logins?
     

    Attached Files:

  11. morphius111 thread starter macrumors member

    Joined:
    Jul 2, 2010
    #11
    I am using the same login. Same password. Drives me crazy here.
     
  12. aarmstrong27 macrumors regular

    Joined:
    Jun 20, 2012
    #12
    Very odd.

    And did you SIGN OUT of iMessage on your iPhone? (Not just switch off)
     

Share This Page