Messages

Discussion in 'Mac Apps and Mac App Store' started by superscape, Mar 9, 2015.

  1. superscape macrumors 6502a

    superscape

    Joined:
    Feb 12, 2008
    Location:
    East Riding of Yorkshire, UK
    #1
    Hi,

    I'm sure I'm missing something stupid, but I'm having an issue with Messages on the Mac/iPhone.

    I tend to have my MacBook on during working hours and use Messages there. I then switch to my iPhone when I leave the office. If I start a conversation on my Mac, then when I go onto my iPhone its not there.

    What's more, if new messages are sent to me, they don't come up on my iPhone, but only appear on my Mac.

    My understanding was that conversations could be continued between Mac and iPhone. Did I misunderstand, or have I set something up wrongly?

    Any suggestions welcome!

    Thanks in advance
     
  2. jack1011 macrumors member

    Joined:
    Nov 7, 2014
    #2
    In the Messages settings on your iPhone, do you have Text Message Forwarding enabled?
     
  3. superscape thread starter macrumors 6502a

    superscape

    Joined:
    Feb 12, 2008
    Location:
    East Riding of Yorkshire, UK
    #3
    Hmmm. No, I don't.

    Just tried turning text message forwarding on on the iPhone and it responded saying I need enter a code shown on my Mac. However, nothing's shown on my Mac! The Mac and iPhone are both on the same local wireless network and have internet access.

    Any suggestions?
     
  4. jack1011 macrumors member

    Joined:
    Nov 7, 2014
    #4
    Try this (there's a few steps, but it's simple):

    Go to Messages settings on the Mac, go to Accounts, select your iMessage ID and click "Sign Out"

    Go to Messages settings on your iPhone, and turn off iMessage.

    Sign back into Messages on Mac (make sure "Enable this account" is checked)

    Turn iMessage back on on your iPhone

    Try again to enable Text Forwarding in the iPhone Messages settings.
     
  5. superscape thread starter macrumors 6502a

    superscape

    Joined:
    Feb 12, 2008
    Location:
    East Riding of Yorkshire, UK
    #5
    Thanks for that.

    It worked in the end after much frustration using my office network, I tried again on my home network and it magically worked. Most mysterious.

    I assume *something* important it blocked from my office network, although that's surprising since most stuff is allowed.

    Ah well, working now - in part thanks to your info - so thanks very much for your help!
     

Share This Page