Messaging not syncing with iPhone

Discussion in 'iPad' started by bkitchen0406, Mar 18, 2012.

  1. bkitchen0406 macrumors member

    Joined:
    Feb 5, 2012
    #1
    When I get a message from an iPhone for example to my iPad, it does not show up on my iPhone as well and vice versa. Is there's work around for this.
     
  2. Fynd macrumors 6502

    Joined:
    Aug 11, 2010
    #2
    Make sure you have your caller ID on your iPhone set to your email and not your phone number. What's likely happening is that people are texting you back on your phone number, which in my experience doesn't work properly with ipad/iphone. Bit of a mess IMO. I had to delete the thread on my girlfriends phone from my cell number, because she kept replying in that thread instead of the one from my email. Now that that's cleared up everything syncs perfectly with my mac/ipad/iphone.
     
  3. bkitchen0406 thread starter macrumors member

    Joined:
    Feb 5, 2012
    #3
    Thanks for your help. Having looked at the setting in the iPhone, I'm not sure where this is located
     
  4. drb1992 macrumors 6502

    drb1992

    Joined:
    Oct 4, 2011
  5. bkitchen0406 thread starter macrumors member

    Joined:
    Feb 5, 2012
  6. rnelan7 macrumors 6502

    rnelan7

    Joined:
    Nov 9, 2009
    Location:
    Boise
    #6
    Settings -> messages -> receive at -> add another email
     
  7. macguy11 macrumors member

    Joined:
    Mar 19, 2011
    #7
    When I text someone from my phone and then later my iPad, they say that it shows up in two different threads for them. Does anyone know why that is or is that just the nature of iMessage?
     
  8. swiftaw macrumors 603

    swiftaw

    Joined:
    Jan 31, 2005
    Location:
    Omaha, NE, USA
    #8
    The problem is your phone is sending messages from your phone number, whereas your iPad is sending messages from your AppleID. You need to go to Settings->Messages->Receive At->Caller ID on your iPhone and select your AppleID rather than your phone number.
     
  9. bkitchen0406 thread starter macrumors member

    Joined:
    Feb 5, 2012
    #9
    Ok it worked, thanks to uguys I figured it out. One thing to remember, you have to send the text message to the email. So even after u do all that is mentioned above it does not work unless the sender selects your email. That's what the first guy was saying. That is total ****, but at least it's a work around
     
  10. Shorties macrumors 6502a

    Joined:
    Jul 22, 2007
    Location:
    Southern California
    #10
    Yeah, its one of those things I just don't get. Why can't all iMessages be synchronized in the cloud like everything else in iCloud. WebOS let you synchronize all messages between the HP Touchpad and the Pre. (WebOS even had native support for things like Skype so that it was all integrated into one messaging program).

    If you tell your senders to delete your iMessage thread related to your phone number and to add your email to your contact, it should always iMessage your email whenever they text you. I've been working on this with my friends for a while, I've gotten the majority of the people I talk to on a regular basis setup correctly.
     
  11. driftwoodtea macrumors member

    Joined:
    Oct 19, 2011
    Location:
    Edinburgh, UK
    #11
    Thanks for this!
     

Share This Page