Messed up fonts

Discussion in 'macOS' started by Dagless, Apr 10, 2006.

  1. Dagless macrumors Core


    Jan 18, 2005
    Fighting to stay in the EU
    Any clue how to fix this? I've tried cleaning up the font cache but with no help :(

    Irritating as hell too. I can read it. but man! it hurts.

    any help would be so appreciated :D

    edit: notice how it only applies for some sites. Google being the most used of mine.

    Attached Files:

  2. berg macrumors member


    Apr 12, 2006
    Hi There ...

    Some suggestions ...

    You can run Font Finagler to purge these cache files in an attempt to restore normal behavior. If you use Font Finagler but the problem remains, then it could be caused by an underlying OS X font-handling bug, by a font conflict, or by a corrupt or less-than-ideal-quality font. Try removing fonts to isolate the problematic fonts that are causing this behavior.

    Important: Close all other applications before cleaning caches...

    Or ...
    Move to the Trash Safari Prefs ..
    Users/Your Account/Library/Preferences/

    Or ..Trash the Safari in Applications ..
    Custom Install in Tiger ... Reinstall Safari
  3. Orlando Furioso macrumors 6502

    Orlando Furioso

    Apr 12, 2005
    Open up "Font Book" and check to see if that god-aweful font somehow managed to get in your "Web" collection (left-hand column... at or near the bottom). Click it to see what fonts if holds. If that font is in there, disable it and/or delete it.

    This has happened to me once and on the computers at school all the time. Not sure what causes a nasty font to take over as a default web font. Especially since I never downloaded or installed the font to begin with. For some reason they are always hard to read too. Weird.

    Hopefully this solution works for you.
  4. calebjohnston macrumors 68000


    Jan 24, 2006
    Someone else had a problem like this today - it was their.. Arial font I believe that was messed up. They had to disable a certain font in fontbook and it fixed it. Try looking through the threads.
  5. yvovandoorn macrumors regular

    May 2, 2005
    Renton (suburb of Seattle), WA
  6. dagriggs macrumors newbie

    Apr 14, 2009
    messed up fonts

    I suffered trying to read my browsers for too long. I finally solved the problem. Changing font default in browser did not help. Downloading software did not help. Repaired Permissions did not help.

    I went to Applications - Fontbook - opened Fontbook - chose All Fonts - chose Alien League - clicked the check box at the bottom to turn it off - chose Ariel Hebrew - clicked the check box at the bottom to turn it off - restarted and it was fixed. I do not know which font was the problem but I don't think I need either.

Share This Page