Messed up my BootCamp, how do I fix it?

Discussion in 'Windows, Linux & Others on the Mac' started by rastersize, Apr 11, 2009.

  1. rastersize macrumors member

    Apr 9, 2008

    I have the following setup:
    One harddrive for Mac OS X (one partition) and another one for Windows (Vista 64bit) and a scratch/share partition (two partitions on the second harddrive).

    Today I "need" to put some files larger than what FAT32 formatted scratch/share partition allows for so I opened "Disk Utility" and selected the partition. I proceeded with selecting the "Erase" tab and choosing the volume format Mac OS Extended (Journaled) and clicked the "Erase..." button (knowing that any pointers to the data on that partition would be lost). So far so good and the sun was shining happily upon me.

    But then a few hours later (a few minutes before this post) I tried to boot up into my Vista installation but was met with the error message "no operating system". So I rebooted again and booted up into Mac OS X witch worked fine and reverted the partition to a FAT32 partition and tried again. No I got a different but similar error "no operating system on this device".

    So can I fix this? I would be rather happy if I didn't have to reinstall Vista (as it's everything but fun). Basically I think what I want is to re-run the setup of the bootcamp setup but without the formatting. Just like running "grub" in *nix. But I have no idea how to do this? Or should I do something else to fix it? Please help!

    Thank you in advance!

    (Note: The error messages aren't word-by-word but the meaning of them.)

    Edit: If I open the information window for the "Windows" partition in "Disk Utility" the flag "Bootable:" is set to No. Just noticed this, not sure if it's important or not in this case.

    Edit 2: Would the following work (that is, not break my ability to boot OS X)?
    1) Boot with your Windows Vista DVD
    2) Select "R" for the Recovery Console (Correct me if this is wrong)
    3) When the command Prompt appears .. 
    Type ... fdisk /mbr ... OR
    Type ... fixboot ... OR
    Type ... fixmbr

Share This Page