Messed up partition on 2 drives

Discussion in 'Windows, Linux & Others on the Mac' started by Demigod Mac, Aug 13, 2015.

  1. Demigod Mac macrumors 6502a

    Joined:
    Apr 25, 2008
    #1
    OK so, I got Windows 10 EFI working beautifully on my 5,1 Mac Pro, but I think I made a mistake. I used the Windows-Bootcamp control panel to select OS X as the default and rebooted. It caused my Mac to boot in verbose mode, but otherwise everything looked normal after it was done, but I suspect it messed with the GUID partition tables on some of my drives.

    Now my Windows (dedicated drive)'s EFI partition and internal Time Machine volume show up in Disk Utility as disk1s1 and disk4s3, respectively, and fail to mount in OS X.

    Bizarredly enough, the Time Machine volume now shows up as a Microsoft Basic Data (FAT) drive in Disk Utility but as a normal, working HFS volume in Windows! Did the Mac replace the GUID partition tables with hybrid MBR-GUID tables?

    Already tried resetting PRAM and checked /etc/fstab (there was one but it was blank)

    Any suggestions on how to fix this without having to wipe and reformat those drives?
     
  2. Demigod Mac thread starter macrumors 6502a

    Joined:
    Apr 25, 2008
    #2
    Was able to fix it. GPT fdisk detected the Bootcamp partition was oversized and auto-repaired it, now it works.
    http://www.rodsbooks.com/gdisk

    It couldn't fix the Time Machine volume, but I reformatted that partition and just started over with it. No big deal.
     

Share This Page