Messed up Permissions, Reinstall Snow Leopard?

Discussion in 'macOS' started by Yeesha, Mar 6, 2010.

  1. Yeesha macrumors newbie

    Joined:
    Aug 31, 2008
    #1
    I had a bunch of files with incorrect permissions so I wanted to change the Everyone group and populate all the permissions in all folders. I went to the Hard Drive and chose Apply to Enclosed Items but I hadn't changed the permissions yet so it populated the Everyone group as Read Only throughout the entire HD. After it finished I went back to my hard drive, changed the Everyone group to Read/Write then populated the permissions to Apply to Enclosed Items.

    Flunky stuff started happening after that.

    I ran Disk Utility and repaired the permissions which had TON of problems. Then I checked the disk and it told me to repair the disk so I put in Snow Leopard and tried to boot from it. It stayed at the gray startup screen until I force-restarted at least 10 times. Finally it booted from the CD and I repaired the disk and restarted booting from the HD. It froze at the gray screen again and wouldn't let me eject the CD. I restarted at least 25 times, tried forcing the disk out (scratching it probably) until finally finding the hold-down-trackpad solution and ejected the disk. Restarted and it still froze at the gray screen. I restarted in safe mode (holding the shift key) and then restarted once I'd logged in successfully. Seemed to work fine except for a few weird issues. I opened Pages (which I use every day) and I got the message saying I was opening an application for the first time. Same thing with Firefox. Parallels and VMWare Fusion were both giving me errors saying to check to see if I had permission to run the program.


    I talked to the Genius bar and they told me to reinstall Fusion and reinstall Snow Leopard.

    I reinstalled Fusion and it works fine, but I'm really reluctant to reinstall Snow Leopard. For one, I may have scratched the disk so I don't even know if I *could* reinstall it. For another I have a TON of applications and settings I don't want to lose and have to reinstall.

    After the Genius bar appt. I re-ran the disk utility and repaired disk permissions and it came up with only a couple problems.
    Repairing permissions for “Macintosh HD”
    Permissions differ on "System/Library/CoreServices/RemoteManagement/ARDAgent.app", should be drwxr-xr-x , they are drwxr-xrwx .
    Repaired "System/Library/CoreServices/RemoteManagement/ARDAgent.app".
    Permissions differ on "usr/share/derby", should be drwxr-xr-x , they are lrwxr-xr-x .
    Repaired "usr/share/derby".
    Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired.
    Permissions differ on "Library/Application Support/Apple/ParentalControls", should be drwxrwxr-x , they are drwxr-xr-x .
    Repaired "Library/Application Support/Apple/ParentalControls".
    Permissions differ on "Library/Application Support/Apple/ParentalControls/ALRHelperJobs", should be drwxrwxr-x , they are drwxr-xr-x .
    Repaired "Library/Application Support/Apple/ParentalControls/ALRHelperJobs".

    Permissions repair complete​

    I just ran it again and it gave me this:

    Verify permissions for “Macintosh HD”
    Permissions differ on "usr/share/derby", should be drwxr-xr-x , they are lrwxr-xr-x .
    Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired.

    Permissions verification complete​

    My latest problem with my computer (Macbook Pro) is that I can't connect to a wireless network at someone's else's house. I set up the network in the first place and I've never had problems connecting before. The only thing I can think is that it's related to the permissions thing from the other day. The Genius bar told me that reinstalling Snow Leopard was the best idea because when you start messing with permissions en masse like that you mess up a lot that you don't realize.

    The network is from a Windows XP machine with a Comcast modem and Linksys router. The XP machine connects to the internet fine. When I try to connect it doesn't pull up the network automatically even though it's saved in my network settings. When I put it in manually it keeps asking for a password. I have the settings written down and I'm entering everything correctly. It just keeps asking for a password. The router is set with a WPA2 Personal and that's how I'm entering it in my network settings. I'm just so frustrated at this point.



    So, does anyone have any ideas for fixes that don't require an OS reinstall?

    If I have to reinstall, how do I save all my applications?

    Help please! I have finals this week and I'm dead in the water without my computer working perfectly.
     
  2. -aggie- macrumors P6

    -aggie-

    Joined:
    Jun 19, 2009
    Location:
    Where bunnies are welcome.
  3. Yeesha thread starter macrumors newbie

    Joined:
    Aug 31, 2008
    #3
    I edited my post since you reminded me about my Disk Utility fiasco.

    I did run it and everything is fine except one or two lines that don't sound related at all to my current problem.
     
  4. fernblatt macrumors newbie

    Joined:
    May 22, 2010
    #4
    Yea, same here. Been battling with backups since I replace my iMac.
    I can use any utility, Apple or other, and can't save things from my desktop or other non-system folders - I get a "cannot complete this operation because you do not have sufficient privileges" etc

    I find no bad permissions using Disk Utility.

    I can use terminal and remove ACL's, set permissions to 777, any number of things, but I still get the message that I don't have permission to backup files that I can simply click to open. "Info" shows nothing out of the ordinary. I hate to take a .45 to this brand new 27 inch iMac - particularly since I'd have to borrow the gun from someone else, as I don't have a 45! lol

    Various forum, such as this, seem to have other folks running into the same brick wall with no help.

    The problem is not one of simply migrating the files from my old mac to the new mac. My old mac's hard drive died, and I was able to save important items before it totally quit. Any files from that period are not able to be modified!! Can't change ownership, ACLs, etc etc. Same problem dozens if not hundreds of others have had since Snow Leopard.

    Sigh

    Apple support is no help

    (the other month I even had a (third level) support rep chuckle (hehehe, "you're still using POP?") because I told them I still used POP for mail. Seems they no longer send me surveys after support sessions these days either. are they really trying to emulate microsoft??? LMAO)
     
  5. Hal Itosis macrumors 6502a

    Hal Itosis

    Joined:
    Feb 20, 2010
    #5
    Sounds like you're comfortable with Terminal, so do this then: tell us about one specific problem-pair. I.e., some particular source item and the corresponding target folder to which your attempts at copying one over to the other trigger these error dialogs. Use full pathnames to describe everything, and list both using Terminal (with the options shown below).

    E.g., if some file named "foo" on your desktop complains when you try copying it to the folder "bar" on a disk called "baz", then show us this listing:

    ls -alOe /Users/you/Desktop/foo /Volumes/baz/bar

    [of course, 'you' 'foo' baz' and 'bar' will need to be replaced by the real names over on your end.]

    BTW, are you logged into an admin account or no?
     
  6. Damo01 macrumors regular

    Joined:
    Feb 11, 2010
    Location:
    Australia
    #6
    See here. Just ignore the messages that been modified and that it can not be fixed. Unless of course there a problem. Just reinstall snow leopard or reinstall the combo updates.
     

Share This Page