Messed up with my partitions

Discussion in 'Mac Basics and Help' started by Poimu, Oct 9, 2014.

  1. Poimu macrumors newbie

    Joined:
    Oct 9, 2014
    #1
    Hello,

    I think i messed up too much by myself my disks so i will try to find help out there. :p

    I had multiple partitions, Mac (yosemite) / Windows, and i tried to install Ubuntu as a third partition. Dunno what i did exactly but after that i couldn't boot on windows anymore so i decided to wipe everything and have a fresh & clean install with only a Mac partition.

    I tried to use bootcamp in order to remove the broken Windows partition. Unfortunately, i did only have the option to install a new bootcamp partition. Therefore, i jump'd on the first solution i found on the internet, which was to delete the partition through disk utility and then partition and "-" the bootcamp partition.

    From now on, i have this in my disk utility (in debug mode) :
    [​IMG]

    And when i check partitions on my disk (a 128gb ssd which by the way is call'd bootcamp for i don't know what reason) i have this :
    [​IMG]

    I'd like to do a clean install, with only a Macintosh HD Partition. But i don't know how... It's like my old windows partition size (40GB) is lost.

    Please help :p
     
  2. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #2
    I think your problems started with the Yosemite install. That turns the Yosemite partition into a core storage volume that cannot be manipulated normally in Disk Utility. I can see at the bottom there in Disk Util you still have core storage on (that logical volume note there).

    Open Terminal and enter the line below then tell me the output and we can try and undo this.

    Code:
    diskutil cs list
     

Share This Page