Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors newbie
Original poster
Jul 2, 2023
New Zealand

I am having a lot of problems access a Facebook page I have been assigned Partial access to via Meta Business Suite on my IPhone and IPad. It was working fine until last week now every time I try go into the Meta Business Suite app I get a white screen of death. I have tried everything - I've had my access revoked and reassigned and I just get a loading wheel when I click the link to Review it. I can see that I have the Page and there is a MANAGE PAGE option when I go to Pages in my facebook account but when I click on it, it's just like a dead button. If I uninstall the app it will reload to the log in screen then just freezes. If I close that and go back in I get the white screen of death again.
I get notifications that there are messages on my home screen but when I click on them I can't action them.

I've rebooted the phone and Ipad; uninstalled and reinstalled the Facebook and Meta Business Suite App dozens of times, logged out of Facebook, changed my password, tried Chrome, Safari, Edge; cleared caches and browsers. I'm on the latest IOS (v16.5.1).

I can manage the Page using the Desktop app on my PC but not on the Desktop App on my Ipad. It makes no sense.

I feel like perhaps it's to do with my devices not being current enough (IPhone 11 and IPad 9th Generation) but it was working up until a week ago!!

If anyone has any suggestions, that would be appreciated.


macrumors 6502a
Feb 10, 2021
Tried my app and it works on my phone. I’m on a 14 Pro Max. I’m assuming the cellular tab is on in your devices? I don’t use this (Business Suite) anymore and advertising on Facebook was a waste of time and money.

You want to know what actually did work for me? Advertising on radio - who would have thought! 🤣 It did cost me 3 grand but at least it worked.
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.