MetaX zero byte error. HELP PLEASE!

Discussion in 'Apple TV and Home Theater' started by elmn8r, Sep 7, 2008.

  1. elmn8r macrumors newbie

    Joined:
    Sep 7, 2008
    #1
    I've searched the forum and found a few references to the MetaX zero byte error but nothing that really helped me. I'm encoding movies from .VOB files using HandBrake SVN 1477 and the Apple TV2 preset. I then modify the preset to include 64 bit mp4 and AC3 pass thru. HandBrake works perfectly and I have an .m4v file that I can play on my Apple TV2 with no issues.

    Now here's the problem. Every movie I've done this way, MetaX gives me the zero byte error message and won't write any of the metadata. If I change the extension to .mov from .m4v, MetaX will crash. I did try using VisualHub on a few movies and MetaX works fine on the .mov files it creates.

    It seems everyone here is using MetaX quite successfully. Is anyone else having issues with MetaX on .m4v files created by HandBrake? I wish MetaX had a support forum...
     
  2. crotalus99 macrumors regular

    Joined:
    Dec 4, 2007
    #2
    I have had this happen occasionally, but not on a regular basis. All my files are either mp4 or m4v, so I have no experience with mov files though. From what I remember I would try to write the metadata again and it usually worked.

    Sorry if this wasn't much help.
     
  3. eddyg macrumors 6502

    Joined:
    Sep 5, 2003
    Location:
    Christchurch, New Zealand
    #3
    Well you can't just change the extension from mp4 or m4v to mov, they are slightly different container formats, so the contents of the files are different. That would cause a program reading and expecting one container to get confused.

    MetaX has always worked fine on .m4v's as produced by HandBrake, might I suggest that you delete your copy of MetaX, including preferences, and then redownload and install. What you are observing is not normal.

    Try looking through your MetaX prefs and change some settings to see if that helps. Under "Files" I don't have anything ticked, and I tick the support for large files (64) in General - if encoding using 64bits make sure you select this, even if the file is less than 4Gb.

    If you continue having issues consider contacting the author to request assistance. He's a good guy.

    Cheers, Ed.
     
  4. haze macrumors regular

    Joined:
    Nov 11, 2007
    #4
    I encountered this on occasion when I didn't have enough HDD space. If I recall MetaX writes a temp file, so you need at least enough free space as the size of the movie.
     
  5. yancey47 macrumors regular

    Joined:
    May 21, 2008
    #5
    bump.. i got this today trying to code Futurama. MetaX still put the untagged episode in iTunes, only in the movies section, and with only the title. As if I just dragged and dropped it. Any clues? thanks.

    Got all the latest greatest editions of everything and it tagged another series just fine right before.
     
  6. Sorcerer2020 macrumors newbie

    Joined:
    Nov 8, 2008
    #6
    Losing audit or video playback

    I have some movies that I have ripped from CDs that I own - one for Rundown and one for Butterfly effect. they were ripped using Handbrake and .m4v

    They are about 2.25 to 2.5gb. they play fine.

    Once I tag them using MetaX 2.4.6 they either lose their audio playback or video playback - not both - audio is just silent, video is just black screen. This is true whether I use Quicktime to play them or play them in itunes.

    Appreciate any help.
     
  7. JonHimself macrumors 68000

    JonHimself

    Joined:
    Nov 3, 2004
    Location:
    Toronto, Ontario
    #7
    Are these files that you have RE-edited using metax or is it on the first edit? I've had this problem with files that I've edited, then had to go back and add information.
     

Share This Page