Mic issue on boot camp: Sounds very deep like darth vader

Discussion in 'MacBook Pro' started by dudeitsjay, Sep 19, 2009.

  1. dudeitsjay macrumors regular

    Joined:
    Mar 26, 2009
    #1
    Windows XP 32bit Bootcamp
    Snow Leopard OSX and used the bootcamp drivers from the snow leopard dvd.
    2.66ghz Macbook pro 15'' Sept 2009

    Just bought this macbook brand new today and installed bootcamp and tried running ventrilo, only to find that people thought I was darth vader or jigsaw from the Saw series. I went into the audio properties from control panel and tested the hardware and such, and surely enough the mic comes out back to me like I'm darth vader. REALLY low (deep voice, not low volume) and really hard to discern what I'm saying. It's not just a ventrilo problem. Though, I haven't checked to see if my mic is faulty, as I've yet to use the mic on the Leopard osx partition.

    Anyone have this issue before?

    I've had my share of macbooks over this summer and never had an issue like this. The only difference I notice from the rest of the macbooks is that this 15'' with the problem is using Cirrus Logic HD Audio for the input and output (mic).

    Any help would be awesome!
     
  2. ronin510 macrumors member

    Joined:
    Jul 23, 2006
    #2
    This is (little) known problem with the mid-2009 MacBook Pros. The Apple provided Windows drivers (from either Mac OS X 10.5 or 10.6) don't work properly with sound and mic.

    There are several long Apple Support Forum threads concerning it:

    http://discussions.apple.com/thread.jspa?threadID=2037093&tstart=0
    (This one's titled "Very Poor Volume Output - Windows XP" but the Mic and Sound issues are related)

    If you're experiencing the sound problem, there's a patched version of the drivers out there. There's no current fix for the mic, aside from using a USB mic or headset.

    If you read through the linked thread, people have reported it to Apple support and there's no word on when a fix will be coming out. The support staff did say, though, that the more people who report the issue, the higher the priority will be for the fix.
     
  3. rgarjr macrumors 603

    rgarjr

    Joined:
    Apr 2, 2009
    Location:
    Southern Calif
    #3
    Sounds like a driver problem. Not much support from Apple on that. Call Apple and complain.
     
  4. dudeitsjay thread starter macrumors regular

    Joined:
    Mar 26, 2009
    #4
    Yeah thats unfortunate. My macbook pro 17'' 2.8ghz/500hd newest one worked fine. My macbook pro 13'' 2.53ghz newest one worked fine, my macbook air rev b worked fine, and my macbook pro 15'' late 2008 unibody worked fine. This new macbook pro 15'' 2.66ghz with the builtin battery has been the only one with this problem and the only difference is the Cirrus HD Audio.

    I've used the latest fixes that are for bootcamp from the snow leopard osx dvd. Even tried backing to the regular leopard osx dvd. Neither work. sadly, 1 usb is taken for my cooling pad, and the 2nd used for my logitech mouse. Looks like I'll need an expansion and a usb mic...
     
  5. mrsir2009 macrumors 604

    mrsir2009

    Joined:
    Sep 17, 2009
    Location:
    Melbourne, Australia
    #5
    Running Windows on a Mac is bound to cause minor problems like that. Just a small glitch that they need to iron out...
     
  6. ronin510 macrumors member

    Joined:
    Jul 23, 2006
    #6
    You have a 13" MacBook Pro with a working mic under Windows? My 2.26Ghz one doesn't work under Windows XP.
     
  7. dudeitsjay thread starter macrumors regular

    Joined:
    Mar 26, 2009
    #7
  8. ronin510 macrumors member

    Joined:
    Jul 23, 2006
    #8
    Oh, I misunderstood. Those were the patched drivers I referred to initially. They fix the sound, just not the mic.

    For those having problems, please consider sending Apple feedback (bug report): http://www.apple.com/feedback/macbookpro.html

    The more people who complain, the higher the priority this problem will be given.
     
  9. dudeitsjay thread starter macrumors regular

    Joined:
    Mar 26, 2009
  10. oregon2 macrumors regular

    Joined:
    Jul 7, 2009
  11. dudeitsjay thread starter macrumors regular

    Joined:
    Mar 26, 2009
    #11
    hah. Just wanted to update on something weird that happened yesterday.

    I was playing Heroes of Newerth (on xp 32bit) which has a builtin voip set to the cirrus board output. I just talked on it and people heard me clearly and normally. Then I switched into ventrilo (With HoN still on) and it worked perfectly as well! About an hour afterwards, when I left my computer to idle, I come back, with heroes of newerth long closed, and now my ventrilo still sounds low and wrong. Weird huh? I haven't given it another run to replicate the anomaly, but will do when i get the chance.
     

Share This Page