Micro SD Card Reader Not Showing Up In Finder

Discussion in 'Mac Basics and Help' started by steiney, Jan 8, 2013.

  1. steiney macrumors 6502

    Nov 6, 2009
    Hello All!

    I've got a general question and not sure where better to post it. I have an Elago Nano 2 micro sd card reader (here). Yesterday, I tried to eject it but it wouldn't eject and gave me an error message. Instead of force ejecting it through Terminal, I just pulled it out. I got the normal error message about not ejecting properly, but when I tried to put it back in the computer won't recognize it.

    I used a different card reader to test the card and it loads fine. So, the Elago card reader is the problem.

    I've had a card reader go bad, but it seems strangely coincidental that this card reader died at the same time that I was having eject problems.

    I've tried restarting the computer which didn't help.

    If anyone has any ideas of suggestions, I would love to hear them!

    Thanks in advance,

  2. treatment macrumors member

    Aug 7, 2012
    Card readers and the cards themselves are finicky.
    I have about ....8 card readers, only one of them at the moment works, and countless Micro SD cards, some that can be read by one reader and not the other.
    FACE IT: the technology is pretty simple, and pretty crappy.
    I don;t think there are any standards that companies MUST adhere to, it's the only thing I can think of.
    Also, those little cards are HIGHLY susceptible to HUMIDITY.

    Living in a country with 98% humidity, I am actually reconsidering whether I should buy an SSD for my laptop.
  3. steiney thread starter macrumors 6502

    Nov 6, 2009
    Wow, that's definitely different than the experience I've had with SD cards. I have probably 6-8 SD cards and 2 micro SD cards, and none of the have ever gone bad. Some are expensive brands and others are bargain basement brands. I've owned 3 SD card readers, including the ELAGO mentioned previously, and 2 of them have gone bad.

    I was just wondering if there was something I inadvertently did when I yanked the card reader out of the MBP without properly ejecting. Something that could be reset. But I guess any damage from that would have been to the data on the actual micro sd card and not to the card reader.

Share This Page