Microphone audio input automatically changes.. Skype problem [SOLVED]

Discussion in 'MacBook Pro' started by aznguyen316, Apr 13, 2011.

  1. aznguyen316 macrumors 68020

    aznguyen316

    Joined:
    Oct 1, 2008
    Location:
    Tampa, FL
    #1
    So.. I googled and mroogled and didn't come up with anything real solid, so I'll ask here.

    My internal microphone keeps changing the input volume by itself. I like to keep it low since the internal mic is very good. I have ambience noise reduction checked as well. I use skype voice chat when I use the internal mic. It's under the audio preference pane that I'm setting the audio input volume. The problem is it keeps going to maximum input volume. BLAH!! Getting very annoying, especially when I'm gaming and on skype, it picks up the fan noise bad.

    I notice if I keep speaking louder, or make louder noises, the input toggle thing slowly moves toward the maximum end. Why not just stay still??
     
  2. aznguyen316 thread starter macrumors 68020

    aznguyen316

    Joined:
    Oct 1, 2008
    Location:
    Tampa, FL
    #2
    Anyone having this issue? Gonna give this a bump and do some more research..
     
  3. leman macrumors 604

    Joined:
    Oct 14, 2008
    #3
    Skype has an option to auto-manage the mic volume if I am not mistaken. Could be what you are seeing.
     
  4. aznguyen316 thread starter macrumors 68020

    aznguyen316

    Joined:
    Oct 1, 2008
    Location:
    Tampa, FL
    #4
    Hmm gave it a look throughout all the settings options. Didn't see it.

    Edit: okay determined it was within skype that was causing the issue since the mic didn't bump when using a different application.

    Further research yielded this:

    http://forum.skype.com/index.php?showtopic=76062

    Although this is for skype 2.x, it works for 5.x as well. I added these two lines where the link said:

    <AGC>0</AGC>
    <EC>0</EC>

    and found it no longer bumped up the input volume and stayed put. WHEW!

    auto gain control and echo cancellation was what those settings took care of. There used to be a GUI for those to be checked on/off but apparently not anymore.

    Issue solved. Search on MacRumors showed this was an unsolved issue, so hopefully in future searches, this may help. Thanks!
     
  5. vijay_v macrumors newbie

    vijay_v

    Joined:
    Sep 10, 2015
    #5
    The skype forum post quoted above seems to have been taken off (Thanks Microsoft?)

    Found this on another forum:

    Quit Skype and open the folloving file with TextEdit: ~/Library » Application Support » Skype » shared.xml. At the end of the document, you'll see this section:
    <VoiceEng>
    <MicVolume>77</MicVolume>
    </VoiceEng>
    Simply change this section to look like this (adding one new line):
    <VoiceEng>
    <AGC>0</AGC>
    <MicVolume>100</MicVolume>
    </VoiceEng>
    AGC means Automatic Gain Control, and setting it to 0 disables this feature. Set it to 1 if you want to enable it again. The MicVolume can range from 0 (mute) to 255 (full volume). Save the file and start Skype.

    Note: I'm using Tiger and Skype 2.6.0. I have no experience with other OS X and/or Skype versions, but I hope this hint will help some frustrated Skype users.

    --------------
    Hope this helps
     

Share This Page