Microphone port not working on MacMini?

Discussion in 'Mac mini' started by MacNoobGuy, May 5, 2012.

  1. MacNoobGuy macrumors 6502

    Apr 18, 2012
    hey guys, i've tried 2 different mics and both neither seem to work. the sound is perfect, but the mic doesn't seem to work. is there a way i can troubleshoot this like on Windows?

    what USB mics would work with the MacMini?

  2. SandboxGeneral Moderator emeritus


    Sep 8, 2010
    Have you contacted an Apple Store about this problem? Have you had any of these mics work previously on the Mini?

    If you want a USB mic, I'm sure Logitech makes several that will work on OS X, such as this one.
  3. MacNoobGuy thread starter macrumors 6502

    Apr 18, 2012
    i haven't tried the apple store. would i need to take the mac in for them to fix it? seems like a lot of effort for something this small.
  4. SandboxGeneral Moderator emeritus


    Sep 8, 2010
    You can at least call them and describe the problem and see if they can determine if its a hardware issue or not.
  5. chown33 macrumors 604

    Aug 9, 2009
    Sailing beyond the sunset
    There is no mic port on a Mac mini. It's a LINE IN port, not a MIC port.

    See this:

    I've used several different USB mics on a Mac mini. 3 of them were Logitech. They all worked.
  6. WRP macrumors 6502a

    Jul 20, 2011
  7. MacNoobGuy thread starter macrumors 6502

    Apr 18, 2012
    oh damn, so it's not a mic port at all? hmm what USB mics could i try?
  8. McGilli, May 10, 2012
    Last edited: May 10, 2012

    McGilli macrumors 6502

    Nov 11, 2008
    No no no...

    It's a line in and you CAN plug any microphone into it and it works fine. Any audio input device works fine in a line in - you might just need to adjust levels in the system settings for the line.

    I use professional grade RODE microphones plugged into the Mini line in port and it's no problem.

    I swap it out with other audio recording products, and it's never an issue using the microphone.

    WHen you have the microphone plugged in, and the input level is maxed, does the volume meter move at all when you test the mic?

    Also you can see my input level is set high, that's because for some reason the input seems to naturally be lower on the Mini than my MBP. On the MBP I only need it set to half way to achieve the same volume.

    So that is why I suggest cranking the input level and seeing if there's any movement on the meter....

    If nothing registers then try resetting the PRAM on your mini. Might just be a hardware glitch that can be fixed easily.

    Finally - if you do decide to go the USB route - I do use a Griffen iMic on my Macbook Air when travelling with no issues.

    Hope you get it worked out....

    Attached Files:

  9. MacNoobGuy thread starter macrumors 6502

    Apr 18, 2012
    ok i've got the volume set to max and still nothing?
  10. Kebabselector macrumors 68030


    May 25, 2007
    Birmingham, UK
    I've tried normal cheap microphones and they do not work. Maybe your professional ones work, but the ones most people will pick for a few £/$ will not.

    You need a powered microphone on the Mini (probably on the iMac and Macbooks as well).
  11. ironmanlive macrumors newbie

    Oct 6, 2012
    Macmini microphone master level problem

    Hey Guys, i'm trying to do screenrecording with my macmini, i've used a cheap microphone thru jack 1/8 didn't work at all!... so i bought a 80$ SNOWFLAKE MIC, in system preference once selected i see the volume working up and down. however i am unable to change the master mic volume... it is unable...

    At first i had logmeindriver.... some people told me to remove it ! i did!
    i am also using VMWare for my window, and change the setting so windows doesnt use my device...

    I have activity in preference setting from my mic but it still doesnt work with
    Quicktime player during screen recording... neither with a software call screen movie recorder 4.1

    Why i can't adjust my MASTER MIC LEVEL ?????
  12. cosmolee macrumors newbie

    Jun 16, 2012
    What kind of mic?


    It sounds like you are using one of the Rode powered mics - one that has a built-in battery, which provides self-amplification.

    On my 2012 Mac Mini, these passive unpowered mics don't work for me. But plug in a line level signal, say from a mixer, and it works.

    I got confused with this too - I tried three different passive mics, none of them worked.

    I remember back in the day of separate sound cards there would be three different audio ports: line-out, line-in, microphone. Usually laptops pair a mic jack with a headphone jack.

    Where Apple is confusing us is that rather than pairing a line-level-out with a line-level-in or the usual laptop pairing of a mic (in) jack with a headphone (out) jack, they mixed things up by instead pairing a line-in with a headphone jack.

    Our normal expectation is that if we see a headphone jack, we expect the opposing jack to be a mic jack, not line-level.

  13. TechBot macrumors newbie

    Dec 26, 2012
    USB Sound Card

    Couldn't you use a cheap usb sound card like so. USB SOUND CARD this one looks like its from :apple:apple.
  14. velvetlounger macrumors member


    Jun 12, 2012
    I was just on with Apple Care today for the same problem. I have three microphones that I tried and none work. As I recall they all worked in the past. After jumping through all the hoops with Apple Care I decided to try them in the two other Mini's in my house. None of them worked. So then I tried all three in my old G5 and a Dell Netbook, still nothing works. So apparently all three of my microphones went bad at the same time?? this is just strange.
  15. Panther Al macrumors member

    Oct 24, 2011
    The problem is as others said: The Mic's themselves.

    Had the same issue, and the solution was to get a powered mic - the line in just isn't built to take the low level input your typical headset mic so it will never pick it up. Your only real bet without buying a new mic or amp, is to get an adaptor that allows you to plug your 3.5mm jacks into a USB port, where it then becomes a moot point.

    Which is weird, as the line in on my old MacBook takes the mic just fine. Just not the 2011 mini.

Share This Page