Microphone problem on MBP

Discussion in 'Mac Accessories' started by jon08, Jan 8, 2009.

  1. jon08 macrumors 65816

    Joined:
    Nov 14, 2008
    #1
    How can I make my headset microphone (or any other "pluggable" microphone) work on my previous generation MBP??

    The thing is that always when I use Skype/Gtalk for talking, my computer always utilizes the Internal Mic, which makes my voice sound more "robotic", well, unnatural. Besides, the other person can always hear my every more on the laptop, i.e. typing.

    I have already tried System Preferences > Sound > Input and then highlight "Line In Audio Line-in port", but nothing happens! Am I doing something wrong? Should I do more than just click on "Line In Audio Line-in port"?? Is there a different process of activating it or so?

    It keeps utilizing the internal mic. I have tried two of them already: my headset mic and a separate mic, but no difference.

    Could it possibly be a port problem??:confused: I hope not...
     
  2. jon08 thread starter macrumors 65816

    Joined:
    Nov 14, 2008
    #2
    In addition, I just downloaded Sound Recorder Mac and tried to record a voice clip.

    When Built-In Microphone option was selected, it obviously recorded it with all other little noises, well, because it's the internal microphone, which picks up everything in laptop's vicinity.

    But when I selected Line-in, all it did was to record silence, nothing else.

    I'm really confused....what's wrong???:confused::(
     
  3. waw74 macrumors 68030

    Joined:
    May 27, 2008
    #3
    not really a solution for your problem, but a work around. Have you tried a bluetooth headset. works great and fairly easy to set up. and no annoying wires.
     

Share This Page