Microsoft Framework X error with OS 10.3.2

Discussion in 'Mac Apps and Mac App Store' started by rma, Jan 13, 2004.

  1. rma macrumors newbie

    Jan 13, 2004
    I just installed MS Office for OS X on a brand-new Powerbook G4 running 10.3.2. Unfortunately, I made 2 mistakes. I didn't delete the Test Drive before installing, and I may have overwritten one of the cache files (in Documents:Microsoft User Data: Office X Identities: Main Identities: Cache) with an older file.

    Right now, whenever I start any MS Office component (Word, Excel or PP), I get an error message:
    "An unexpected error occurred while trying to load the Microsoft Framework X
    The program then works, it's just irritating (and a little worrisome).

    Based on info I found on various newsgroups, I tried removing and re-installing Office again (I had already removed it, deleted the Test Drive, and re-installed it). Didn't work.

    I also checked ownership and unlocked status on files in:
    Microsoft User Data: Identity:
    Library: Preferences
    Applications:MS Office X:Office
    and couldn't see any problems.
    I ran Disk Repair to verify and repair permissions. No luck.

    Does anyone else have any solutions to this?
  2. MoparShaha macrumors 68000


    May 15, 2003
    San Francisco
    I'm having the same problem. I don't have a solution though, I've just been ignoring it. Hopefully someone has the solution.
  3. MisterMe macrumors G4


    Jul 17, 2002
    Re: Microsoft Framework X error with OS 10.3.2

    Why don't you run the uninstaller for M$ Office v.X Test Drive?
  4. rma thread starter macrumors newbie

    Jan 13, 2004
    I did run the uninstaller for M$ Test Drive, but unfortunately it was after I had already installed Office the first time (trying to do too many things at once). So I uninstalled Test Drive, and then twice tried uninstalling and reinstalling Office. Didn't work. I don't know that the Test Drive thing was the problem, I just thought it might be since I did an Office installation on another brand new Mac at the same time, where I remembered to uninstall Test Drive first, and Office worked fine on that one.
  5. ororor22 macrumors newbie

    Jan 21, 2004
    framework x

    I have the same problem and can add some info that hints at a future fix.

    Office works with identities which affects who has access to the Entourage address book. This address book is "owned" by the name you give it when you install. In my case, I didn't pay attention to a name when I nstalled and so now the name doesn't match either the OS X system administrator OR the owner's name of the Office address book. So I have no permission to alter the address book. You can see this lack of permission in action if you go into WORD and try to add info to the User Info preference. It doesn't take.

    Yesterday I added a new identity to Entourage, and somehow, in the process got to designate a new address book owner for the new identity. In my case, the new owner name matchs both the OS X and Office install owner. THEN, switching to that new identity within Entourage, i was very surprised to load WORD and find that the annoying Framework X error had vanished. Also, I can now add info to the "owner info preference" within WORD.

    But having two different owners (essentially a different system administrator) for two Office address book identities has made a new problem which i can't solve. My old identity, (which still makes the framework X error to appear) contains all my addresses and all my messages and message folders.

    It was easy to re-load my old addresses into the new identity's address book. i did this by importing them from the apple address book.

    But I still haven't been able to figure out how to load all my messages including its complex folder structure into the new identities version of Entourage.

    So far, I have tried a few things. For example, I located the entourage database file and copied it into the new identities folder. While messages transferred successfully, it also caused the framework X error to re-appear, as well as my inability to enter info into the WORD preference. I thought maybe the database was damaged, so I then tried an address book rebuild by loading Entourage with the op key down. But the database still causes framework problems. So I figure the database itself is causing the framework X problem in some weird way but i can't figure out how to lift the info from the database without moving the old databse itself. Is that clear?

    For now, my interim soultion is simply to use the new identity because I prefer to work without system errors. i will slowly rebuild my new identity's Entourage message structure from scratch. And i still have the old messages on the old identity so it is like an archive, accessible by switching identities within Entourage.

    But does anyone out there know another way to get messages from one identity into another one without copying the database file itself?
  6. superfunkomatic macrumors regular

    Jan 6, 2003
    calgary, ab canada
  7. Yorgo macrumors newbie

    Mar 5, 2007
    Framework library X error due to not removing office test drive first.

    Try deleting both installations (or whichever one is still installed) then go to your Documents folder and delete the Microsoft User Data folder, then reinstall the licenced version of MS Office. This worked for me using OS 10.4.8.
  8. MacsterShake macrumors newbie

    Aug 13, 2007
    Library Frameworks Error when loading microsoft word

    for Office 2004 users:

    I just migrated all my stuff from a PowerPC to the Intel Duo, and ran into that Microsoft Library Framework error. It definitely has to do with the main identity for Entourage. Here's what I did to fix the problem.

    If possible, uninstall and reinstall Office 2004. Back up any data for your existing identities in Entourage.

    Go to your documents folder\Microsoft User Data\Office 2004 Identities\

    Delete any of the main identity folders.

    Open Entourage and set up your identity.

    Close out of Entourage and open up Word again. That should fix the problem.
    Remember this works best with a fresh install of Office 2004.
  9. enjoyfinewines macrumors newbie


    Oct 6, 2010
    San Francisco Bay Area, CA
    I was getting this framework error when opening MS Word too. The solution from MacsterShake worked even though I am not using Entourage. I navigated to the same folder he mentioned:

    \Microsoft User Data\Office 2004 Identities\

    and deleted ALL the identities files in that folder. Then, I ran MS Word again and voila - no more framework error! I've been trying to understand why for months. Thank you MacsterShake! :)


Share This Page