Microsoft Intellimouse Optical with OS X Mavericks

Discussion in 'Mac Accessories' started by gowanis, Oct 26, 2013.

  1. gowanis macrumors 6502

    Joined:
    Sep 22, 2007
    #1
    I am currently using a Microsoft Intellimouse Optical with Mountain Lion. The latest Microsoft driver works, with one caveat - I have to go into System Preferences every time I boot, and click on "Microsoft Mouse" to activate the driver. Its a bit of an annoyance, but I love this mouse. I program the side and wheel buttons to do various things like close current browser tab/window and move "back".

    I guess its a longshot, but does anyone know if this still works in Mavericks? I'm hesitant to upgrade because of this (as well as some other app compatibility).
     
  2. Fishrrman macrumors G4

    Fishrrman

    Joined:
    Feb 20, 2009
    #2
    You might try either "USB Overdrive" or "SteerMouse".

    Both are 3rd-party apps that will give you more control of the mouse.

    My preference is USB Overdrive...
     
  3. gowanis thread starter macrumors 6502

    Joined:
    Sep 22, 2007
    #3
    Thanks I will check it out
     
  4. kant macrumors 6502

    Joined:
    Jul 22, 2004
    #4
    I've got a Trackball Explorer. I started the Mavericks upgrade on my laptop before I left home, so I'll let you know in a little while.

    FWIW, I've not had any problem as you describe with ML and the trackball. Same software.
     
  5. kant macrumors 6502

    Joined:
    Jul 22, 2004
    #5
    Seems to be working fine.
     

    Attached Files:

  6. DeMarc macrumors newbie

    Joined:
    Oct 31, 2013
    #6
    I created an account JUST so I could answer this for you as I know the answer and it is nice to have one posted. I was actually looking up a different problem with mavericks mouse when i saw this one.

    SOLUTION:

    reason you are having to click on the mouse in system preferences to activate the drivers is because the MicrosoftMouseHelper.app is not auto-launching. This is probably due to the driver not updated yet. All you need to do is go into your sys prefs > users > login items and add the app mentioned above at this location (just use the go-to-folder in finder).

    /Library/PreferencePanes/Microsoft Mouse.prefPane/Contents/Resources/MicrosoftMouseHelper.app


    As for your hesitancy to upgrade, I just went from Snow Leopard to Mavericks and so far there are only small pitfalls. If you are in ML, I am betting it is only an upgrade as i keep reading that "this is fixed in mavericks."

    The mouse issue I am having is a big pain though. It has only happened twice so far, and it means I have to at least log out to fix it. The mouse disappears. The cursor i mean. The physical mouse still is active, buttons work, but there is NO POINTER anywhere. It seems to happen when i hit my expose corner, err my bad, mission control to show all apps, then it disappears. As for suggestions, I did not do an upgrade, i did a full clean install. My computer is a macbook pro 17" early 2011.

    Oh and finally, you DO NOT want to use usb overdrive. The reason why the microsoft mouse stands above the rest for mac, is because it has the microsoft acceleration built into the drivers. What this means is how far it travels based on how far you move the mouse and and what speed you did it at. This is the ONE thing I have always praised microsoft over mac, was mac's acceleration never felt natural compared to a windows machine. (keep in mind I have not used a native acceleration in a LONG time so maybe it is better now in recent OS updates)
     
  7. gowanis thread starter macrumors 6502

    Joined:
    Sep 22, 2007
    #7
    Thanks for the reply. When I go to my Library folder and follow the path above, I get to PreferencePanes but do not have any sub-folders. I see the file Microsoft Mouse.prefPane, so I added that. When I boot the pane comes up, so I've saved one step (I don't have to go into settings any more), but I still have to close the mouse pane. Is this the intended result? Of course I'd like to have it just activate without me having to do anything.

    And to confirm, this Microsoft driver works in Mavericks?
     
  8. DeMarc macrumors newbie

    Joined:
    Oct 31, 2013
    #8
    I guess I did not make it clear. You need to right click on Microsoft Mouse.prefPane and show package contents if you are doing it this manual way. You need to add the .APP located at the end of the path i listed. And yes this is Mavericks.
     
  9. gowanis thread starter macrumors 6502

    Joined:
    Sep 22, 2007
    #9
    Thanks, got it now. This is very helpful.

    I'm still waiting to upgrade to Mavericks due to my work remote access being incompatible. Hopefully that will be fixed within a week or so, but now I'm also worried about the Western Digital drives dying under Mavericks. But that's another story...
     
  10. professorjay macrumors member

    Joined:
    May 13, 2007
    #10
    THANK YOU! This worked! I know it had to do with adding something to the login items but had no idea which one.

    And to further clarify, you'll navigate through Finder and then drag and drop it into the login list. You can't navigate directly by using the plus button in the login items because it won't let you view contents there.
     
  11. gludwig macrumors newbie

    Joined:
    Feb 2, 2014
    #11
    Thanks! This solved it for me.

    But as far as "this is fixed in Mavericks" goes, it doesn't seem to be. The Intellipoint OS specs on the Microsoft website still only go up to 10.7, but so long as your fix does the job I can wait.
     

Share This Page