Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

singjai

macrumors member
Original poster
Jan 23, 2014
56
12
I searched it on google and kind of had a feeling it was because I was using dual monitors. This is what I found - https://discussions.apple.com/thread/3766438

Is there any way to fix it? When I try and go on a different screen once my mac is unhooked to my other monitor, I'm not able to drag the pp back on my screen. The only way to fix this problem is by opening display preferences and changing the screen size. Is there another way to keep it from doing this without having the open display preferences? I take my mac to class everyday and opening pp everyday like this gets pretty annoying..
 

campyguy

macrumors 68040
Mar 21, 2014
3,413
957
I use a workaround, but I don't have a solution. I use a 3rd party donationware application named Spectacle (http://spectacleapp.com/) for moving and resizing application windows. I use the "Next Display" and "Previous Display" keyboard shortcuts to move windows between multiple displays and move "orphan" windows to my only display (when I disconnect my MBP from my monitors). I've included a screenshot of Spectacle's Preferences - I've modified several of the standard shortcuts for my own usage, look in the upper right corner for the two shortcuts that I use to move windows between monitors. I've noticed that applications that were issued before ML's "Spaces" came out act like this more often than not. Cheers!
 

Attachments

  • Screen Shot.png
    Screen Shot.png
    98.2 KB · Views: 1,577

Altemose

macrumors G3
Mar 26, 2013
9,189
488
Elkton, Maryland
I searched it on google and kind of had a feeling it was because I was using dual monitors. This is what I found - https://discussions.apple.com/thread/3766438

Is there any way to fix it? When I try and go on a different screen once my mac is unhooked to my other monitor, I'm not able to drag the pp back on my screen. The only way to fix this problem is by opening display preferences and changing the screen size. Is there another way to keep it from doing this without having the open display preferences? I take my mac to class everyday and opening pp everyday like this gets pretty annoying..

My work around would be to hit Mission Control if running Lion or later. It is the F3 key on your keyboard.
 

liya1201

macrumors regular
Sep 8, 2010
141
22
My work around is following:

Go to "Window" Pull-down menu in PowerPoint and click "Zoom Window".

I searched it on google and kind of had a feeling it was because I was using dual monitors. This is what I found - https://discussions.apple.com/thread/3766438

Is there any way to fix it? When I try and go on a different screen once my mac is unhooked to my other monitor, I'm not able to drag the pp back on my screen. The only way to fix this problem is by opening display preferences and changing the screen size. Is there another way to keep it from doing this without having the open display preferences? I take my mac to class everyday and opening pp everyday like this gets pretty annoying..
 

ckopyar

macrumors newbie
Dec 18, 2014
1
3
Reset an "off-screen" window

To reset an off-screen window, such as a powerpoint window that now appears off-screen after you've moved from a dual-monitor to a single screen and isn't able to be dragged back into your main viewer, navigate to "settings > displays", manually toggle between a new resolutions for your screen, and then revert back to the original display setting. This will force powerpoint to reset the window based on the new resolution / dimensions.

In Yosemite 10.10.1, the display resolution will by default to "Best for display". Select the second radio button that reads "Scaled". Additional resolution options will appear at that time. Select any of these other display options to trigger the reset. After confirming that the full PP window is now visible on screen, select "Best for display" once again.

This should resolve the [buggy, annoying, unnecessary] issue.
 

yumyum

macrumors newbie
Jan 9, 2015
1
1
My temporary fix - under 'Window' on the top bar, select 'Zoom Window', then you'll have your powerpoint back to the center of the screen.
 
  • Like
Reactions: OldGreyGuy

dgleb2012

macrumors newbie
Aug 12, 2015
1
0
Reset an "off-screen" window

To reset an off-screen window, such as a powerpoint window that now appears off-screen after you've moved from a dual-monitor to a single screen and isn't able to be dragged back into your main viewer, navigate to "settings > displays", manually toggle between a new resolutions for your screen, and then revert back to the original display setting. This will force powerpoint to reset the window based on the new resolution / dimensions.

In Yosemite 10.10.1, the display resolution will by default to "Best for display". Select the second radio button that reads "Scaled". Additional resolution options will appear at that time. Select any of these other display options to trigger the reset. After confirming that the full PP window is now visible on screen, select "Best for display" once again.

This should resolve the [buggy, annoying, unnecessary] issue.


Thanks for this! Helped me fix this annoying problem.
 

artaylo7

macrumors newbie
Sep 18, 2015
1
0
Reset an "off-screen" window

To reset an off-screen window, such as a powerpoint window that now appears off-screen after you've moved from a dual-monitor to a single screen and isn't able to be dragged back into your main viewer, navigate to "settings > displays", manually toggle between a new resolutions for your screen, and then revert back to the original display setting. This will force powerpoint to reset the window based on the new resolution / dimensions.

In Yosemite 10.10.1, the display resolution will by default to "Best for display". Select the second radio button that reads "Scaled". Additional resolution options will appear at that time. Select any of these other display options to trigger the reset. After confirming that the full PP window is now visible on screen, select "Best for display" once again.

This should resolve the [buggy, annoying, unnecessary] issue.


Thank you! This has been bugging me for months. This is the only quick fix that actually worked. I just changed the resolution and then changed it back and it brought my off screen elements back. :)
 

drytoad

macrumors newbie
Jan 28, 2016
1
0
simple solution is throw your mac out of the nearest window and get a pc. However, if you're like me, and stuck using whatever crap machine your school gives you, then you'll just have to remember to drag your PP back from the mirrored screen before you detach the hookup. I just learned this the hard way that nothing mac does is easy.
 

BrianBaughn

macrumors G3
Feb 13, 2011
9,694
2,446
Baltimore, Maryland
simple solution is throw your mac out of the nearest window and get a pc. However, if you're like me, and stuck using whatever crap machine your school gives you, then you'll just have to remember to drag your PP back from the mirrored screen before you detach the hookup. I just learned this the hard way that nothing mac does is easy.

Yeah! It's like trying to drive one of those horribly complicated Mercedes-Benz cars.
 

Elbowroom Rich

macrumors newbie
Feb 8, 2016
1
0
Thanks for the fix, scratching my head for a good 15 mins there.

simple solution is throw your mac out of the nearest window and get a pc. However, if you're like me, and stuck using whatever crap machine your school gives you, then you'll just have to remember to drag your PP back from the mirrored screen before you detach the hookup. I just learned this the hard way that nothing mac does is easy.

it's a windows (spit) app...
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.