Microsoft Reserved HDD mounting problem on OSX

Discussion in 'Mac Basics and Help' started by thgil, Apr 13, 2011.

  1. thgil macrumors newbie

    Joined:
    Apr 13, 2011
    #1
    Hey everyone, I would really use some help!! I know this might seem like a common question, but upon hours of search I cannot find a solution.

    A few things beforehand:
    1) I just installed windows 7 via bootcamp
    2) I have a Seagate goflex desk 1TB that I use to store files on OSX and use it as a time machine with no problem. It has two partitions.
    3) I have a 2.1 intel duo core macbook

    So I used my seagate HDD to store some big files that I wanted to transfer to windows 7. When I plugged the HDD in, the device was recognized by windows, but I would not access it in any way. So I went to "administrative tools" -> "disk management" to see what's going on. The HDD was there, but the contents were under one big unpartitioned block. For some reason decided to right click "format to MBR" or "GPT", not sure which one. The HDD still couldn't be accessed. But when I went back to OSX, the HDD couldn't be mounted at all. Plus the name of partition became "disk1s1". When I go back to try "format to _____" (whichever one I didn't do first), it still doesn't work on OSX or windows 7. So now I basically have a 1TB HDD full of photos that can't be accessed through windows 7 or OSX....

    Someone please help!!! :(:(:(
    Thanks a lot!
     

    Attached Files:

  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    First of all, you shouldn't have done what you did on Windows - doing that renders the drive's data inaccessible directly (since the partition table's hosed up). You should be able to use drive recovery software to get what you need off there - though I can't make any recommendations as I've never seen a situation like this before.

    Secondly, Windows sometimes requires a drive firmware update to be able to use some externals. I had this happen once - Windows refused to recognize the disk I just plugged in, but when I updated the firmware, it worked perfectly.

    Finally, for some strange reason, Windows XP, Vista, and 7 will not recognize external drives with 2 partitions where the Windows partition is NOT the first one on the drive. I discovered this limitation the hard way - fortunately I had no critical information on the drive at the time, so a simple reformat cured it.
     
  3. thgil thread starter macrumors newbie

    Joined:
    Apr 13, 2011
    #3
    Thank you wrldwzrd89!

    I'll try using a data recovery program.

    Your last comment about two partitions is dead on. My first partition was for OSX, while the second was a windows partition. Another good lesson for me to remember! :eek:
     

Share This Page