Mid-09 MBP 13" - SATA interface issues?

Discussion in 'MacBook Pro' started by tltuolliac, Aug 18, 2011.

  1. tltuolliac macrumors newbie

    Joined:
    Jul 28, 2009
    #1
    I've been dealing with HD issues on my mid-09 13" MBP for the past four months. First, I had my factory-spec 500GB drive fail in April after nearly two years of service. I was able to salvage everything, and bought a 2TB Western Digital external to store it all on. I have been backing up everything with it since then, so I have no worries in terms of data preservation.

    In May, I got a 500GB WD (WD5000BEVT, 5400RPM Scorpio Blue) from Newegg and installed it as a new internal. It partitioned and worked fine for nearly 3 months, when it failed a few weeks ago.

    So I get a WD Scorpio Black (WD5000BEKT, 7200RPM), try to install it, and I get "POSIX reports: The operation couldn’t be completed. Cannot allocate memory" whenever I tried to partition it. I tried formatting it to NTFS on a WinXP install disc, it wouldn't even format from there.

    I also downgraded the EFI firmware from 1.7 to 1.6 in an attempt to get around a problem related to SATA II drives with 1.7, but that didn't work, so I suppose that wasn't the issue. It might have also been a mistake to do.

    I filed an RMA for the Scorpio Black, sent it back, got a 500GB Hitachi and it comes up with the same POSIX error.

    ...EXCEPT when I partition it from an external enclosure. That went smoothly.

    Is there something wrong with my SATA interface (NVidia MCP79 AHCI) that would have prevented the Scorpio Black from formatting, or the last two drives to fail? At the moment, I can't even update the firmware to 1.7 again, because it won't do so as long as I'm starting it up from my WD external's Snow Leopard boot.

    I'm going to try installing Lion to the Hitachi HD. I get the black screen issue with Snow Leopard now, otherwise I would already have installed it on there. If there's a problem with the SATA interface, then I cannot rule out the possibility that when I attempt to install the Lion-ready Hitachi HD into my MBP, it could fail to boot.
     
  2. tltuolliac thread starter macrumors newbie

    Joined:
    Jul 28, 2009
    #2
    And...that is exactly what happened. After I put it in and started it up, the startup icon would flash rapidly between the Apple symbol, the question mark folder, and the no symbol. It simply rejects HDs.
     
  3. bizzle macrumors 6502a

    Joined:
    Jun 29, 2008
    #3
    It's very common for the hard drive flex cable to go bad in that model. Part number is 922-9062. It's possible that your drives were never bad in the first place. The cable issue will cause a lot of file system corruption that will lead to a machine that does not boot. If you can boot your Mac from target disk mode, run SMART Utility on your internal drive. If you see CRC errors or errors under "Total Errors", it's probably the cable. It's very very common. If you do buy one, make sure its new else there is a good chance it'll have the same problem already and I don't know if they changed anything in the cable later in production to fix it.
     
  4. tltuolliac thread starter macrumors newbie

    Joined:
    Jul 28, 2009
    #4
    Well, that's pretty specific, and it's probably what it is. I'll give it a try, thanks.

    I'm relocating within the next week, though, so I'm kind of pressed for time. Would I be better ordering it with the spudger from iFixit for $40 and doing it myself, or taking it to the nearest Genius Bar and sparing myself the labor? Granted, this thing is way past warranty; so I'm erring on the side of the prior.
     
  5. bizzle macrumors 6502a

    Joined:
    Jun 29, 2008
    #5
    No idea what they'll charge at the Genius Bar but it's very easy to do yourself. Take the back panel off and then take the hard drive out. Take the two screws out that hold the cable to the casing (under the bracket you take off to remove the hard drive). Then there are two long screws that hold the other side of the hard drive mount down which also has the IR receiver. It'll then just peal off. It's a ten minute job.
     
  6. tltuolliac, Aug 25, 2011
    Last edited: Aug 27, 2011

    tltuolliac thread starter macrumors newbie

    Joined:
    Jul 28, 2009
    #6
    I picked up the new cable, and I was just following the iFixit guide.

    [​IMG]

    See the 1.5 mm Phillips in the leftmost red circle?

    Mine got stripped while I was trying to remove it. I wound up pulling the rest of the cable out and leaving the screw there for the time being before putting the cover back on. It's running OK without it, but I still can't put the new one in, yet.

    What now?


    I ignored the screw and put the new one over it while fastening the other one in. It's working just as well.
     

Share This Page