Mid 2009 Macbook pro 13" issue

Discussion in 'MacBook Pro' started by Gsss, Feb 16, 2012.

  1. Gsss macrumors newbie

    Joined:
    Feb 15, 2012
    #1
    I was using my laptop last week when the rainbow wheel appeared. Whole system froze up so I did a force shut down, shrugged it off and went to bed. Next day I tried to boot up and after a few minutes of the apple logo and the waiting circle, I got a prohibitory sign (circle with a line through it). Looked around, found no help. Option-s start: would tell me it was "still waiting for root device" and that was it. Reset nvram and pram, no help. Took it in to the Genius Bar where I was told it was a dying hard drive. Tried to backup the data onto my external while still in the store (not sure how he was getting access to it as I could not start up myself) but it would freeze up after a few gb. Went home and used a friends macbook pro to go into target disk mode. All the data was retrieved without a single problem.

    Now I just got myself a new HDD (320GB 2.5" Hitachi Travelstar Z5K500 5400RPM 3.0Gb-s SATA 7mm Notebook Drive 8MB) to replace the supposedly failing stock one. I installed it correctly, but the problem is that 1) It doesn't show up when I hold option on startup, and 2) When booting from the (snow leopard) install disc it does not show my hdd as an available disc to install on.

    I have tried using disk utility when booting from the install disc. The drive shows up but the "untitled" parition inside it is grayed out. I was told the solution was to format it. When I try to format (zero out, 7 pass, etc.) I am given an error telling me it "Cannot allocate memory". So I removed the drive and plugged it in with a sata/usb cable as if it were an external. I was able to format it this way so I placed it back inside the laptop. Still the same problem. Installer not showing the hdd as an option.

    I've read that others with similar problems may have had a failing hard drive cable, but wouldn't my hdd fail to show up in disk utility if that were the case?

    I have been without this laptop for a week and have yet to fix this issue. I am becoming increasingly annoyed, saddened, and desperate, as this is my only personal computer. I am hoping that someone here can be of a little assistance with this issue.

    Thanks.
     
  2. arjen92 macrumors 65816

    arjen92

    Joined:
    Sep 9, 2008
    Location:
    Below sea level
    #2
    I just got my macbook pro back, after the hdd cable was replaced. It's a curious thing (and very stressful, because I always think it's the motherboard).

    I was able to see my hard drive, save the files, but I just couldn't format it. Everything worked, I could even install Lion on my SSD when I put it in another macbook (I also did this with target disk mode). But I couldn't install it when it was in my macbook pro.

    Anyway, when your cable is broke it doesn't mean nothing works. It's just a few things that don't work. I even got the cable out, put it in the other macbook and it would boot without a problem (so the cable worked in another macbook). Still it was the cable in my macbook pro that caused the problem.

    So you could bring your hard drive back (if you want the money) and buy another cable.

    I find most apple service centers (I'm not in America) lazy and don't do a thorough job ("we'll just replace the hard drive, we'll just replace this etc etc"). I now found a company that's really good, they actually try their best to see what's really wrong.
    Personally I think the genius was wrong and it's your cable. I know from experience, my cable went bad twice.

    The hard drive cable is around €30,-. You could install it yourself.
     
  3. Gsss, Feb 16, 2012
    Last edited: Feb 16, 2012

    Gsss thread starter macrumors newbie

    Joined:
    Feb 15, 2012
    #3
    Thank you, thank you, thank you

    Arjen92, thank you a million times. I really appreciate you taking the time to reply to this as I have not been able to find many users with troubles so incredibly close to mine. Thank you for explaining the hdd cable to me as well.

    I am wondering though, if the cable comes with the IR seonsor as well as the plastic piece for holding the hdd in place. I was looking at my cable earlier and it splits into 2 ends. 1 into the hdd and 1 into the plastic with the sensor. If not, how would I connect the new cable to it?

    Thank you again, you have really put my mind at ease.
     
  4. iPagan macrumors regular

    Joined:
    May 31, 2010
    #4
    So, WHAT is wrong?

    Your HD cable or HD??

    OP, I have a situation here almost exactly like yours.

    Last night, my mid 2010 13" MBP suddenly couldn't boot into desktop. It hung at the grey screen with a prohibitory sign(circle with a slash in it).

    This morning, same thing. Did a lot of research. Tried booting into single user mode: command + s at start. It hung at "waiting for root device.". Tried booting into safe mode: shift while starting. Hung at the grey screen, prohibitory sign. Then tried booting from my external usb stick, which has Mountain Lion on it. Hold down Option before start, that is. Still hung at the same grey screen with the same prohibitory sign.

    Even took the MBP to the Genius Bar. The Genius tried to boot into my comp with his external drive. No go. Then he tried to boot into my comp via network. No go, either. Comp hung at the same grey screen with the same prohibitory sign.

    The Genius said it could be the logic board that was the culprit.

    I have insurance on this MBP with Square Trade. They told me that if it was a hardware issue, they would refund the repair cost. If it was a software issue, they could not.

    Given the above description, is it likely a software issue?

    And finally, OP, what solution have you found for your problem?

    I need my MBP to do my work!

    Thanks!
     

Share This Page