Mid 2009 Macbook Pro 15" not sleeping?

Discussion in 'MacBook Pro' started by brettgo1, Jun 30, 2009.

  1. brettgo1 macrumors newbie

    Joined:
    Oct 26, 2007
    #1
    Hey,

    I just bought a Mid 2009 Macbook Pro 15" and installed a Corsair P256 into it. However, for some reason, it is not going to sleep automatically when it is unplugged; instead it will go into a hibernation mode when the battery runs all the way down.

    I haven't changed the default energy saver settings. I was wondering if anybody with the same configuration experienced the same issues as me? What do you think I should do to fix it?

    Cheers

    Brett
     
  2. vanc macrumors 6502

    Joined:
    Nov 21, 2007
    #2
    Check your energy saver settings and make sure on battery power, the Computer Sleep slider bar set to sleep after some time (default is around 15 minutes).
     
  3. brettgo1 thread starter macrumors newbie

    Joined:
    Oct 26, 2007
    #3
    Yes,

    It is set to the default (10 mins) for battery power saving.

    Also, I'd like to note that it will sleep if I close the lid or manually do it from the menu, it's just not doing it automatically.

    Any ideas?
     
  4. kentcoleslaw macrumors newbie

    Joined:
    Oct 29, 2008
    Location:
    Scotland
    #4
    I didn't experience it with the same config, but I did with my C2D iMac (the white plastic one.) I did a 'ps ax' at the terminal and tried killing processes from third-party software until I found the culprit. Turned out that a couple of helper apps from Parallels were hitting the hard drive every so often, which was stopping the machine from sleeping.
     

Share This Page