Mid-2009 MacBook Pro lag issues

Discussion in 'OS X Mavericks (10.9)' started by Stang68, Mar 17, 2014.

  1. Stang68 macrumors 6502a

    Stang68

    Joined:
    May 29, 2007
    Location:
    USA
    #1
    Hi all,

    My mom's mid-2009 MacBook Pro with 2GB memory is slow as all heck. Only 16GB of storage is used on it, with about 140GB free! She's running Mavericks but the computer has been slow for a while.

    We have tried wiping it totally to no avail. Honestly, the only application she runs is Google Chrome. I thought that might have been the culprit but I looked at the CPU usage and Chome, while at the top, isn't using much of anything. I have attached a screenshot of Acitivity Monitor for your reference.

    Do you guys have any suggestions? Thanks!
     

    Attached Files:

  2. ufkdo macrumors 6502

    Joined:
    Oct 30, 2010
    Location:
    Turkey
    #2
    Could you send the screen shot of the memory tab please? And if you view all processes instead of my processes (you can change it in the view menu), it would be more informative.
     
  3. Stang68 thread starter macrumors 6502a

    Stang68

    Joined:
    May 29, 2007
    Location:
    USA
    #3
    Sure, how does this look?
     

    Attached Files:

  4. ufkdo macrumors 6502

    Joined:
    Oct 30, 2010
    Location:
    Turkey
    #4
    Well, looking at the screenshots, everything seems normal. Memory pressure is rather low and 88% idle for CPU is great, too. Your first post indicates that the computer was slow even before mavericks, right? Maybe there is a problem with hardware, for instance with HDD. You should try to repair permission and verify disk (if it reports any problems, repair disk as well) using Disk Utility. That's all I can think of unfortunately.
     
  5. Stang68 thread starter macrumors 6502a

    Stang68

    Joined:
    May 29, 2007
    Location:
    USA
    #5
    I'll give that a shot. Thanks!
     

Share This Page