Mid-2009 MBP Has Been Hard Freezing, I think it may be the SSD or software?

Discussion in 'MacBook Pro' started by Maserati7200, Jun 14, 2013.

  1. Maserati7200, Jun 14, 2013
    Last edited: Jun 14, 2013

    Maserati7200 macrumors 6502a

    Maserati7200

    Joined:
    Mar 17, 2009
    Location:
    11230, Midwood, Brooklyn, NY, USA, North America
    #1
    Please read this fully so you don't end up suggesting something I've already tried.

    I have the Mid-2009 version of the 13" MBP that I received in December 2009. Almost two years ago, I upgraded it to 8 GB of RAM and a 256 GB SSD. Everything has been running smoothly until about 2 or so weeks ago. My computer has been having hard freezes, meaning, it's not simply an application freezing up; force quit doesn't work, the clock stops ticking, the whole system freezes. It was very predictable too. Whether i was watching youtube videos with flash, reading online articles without it (I have ad block) or doing something completely non-flash or web related, my computer would hard freeze after about an hour or two or so of use, requiring a hard reset (holding the power button until it turned off and then restarting).

    I did some research on this and from what I initially found I thought it was problems with the motherboard. However, I found that to be odd because my motherboard was replaced by Apple in September 2012. I read somewhere to try a system hardware diagnostic test (press D upon start up). On the short hardware test, the one that only takes a few minutes, it passed without any problems. Then I tried the longer hardware test, the one that says takes more than an hour. I put that one on and left it alone. I came back every so often and checked on it and it was fine at first. The mouse responded and the test was showing some measurable progress. However I came back, and at 2 hours 11 minutes and 59 seconds into the hardware test, it froze without completing it.

    Then I tried doing something everyone says to do when anything happens: I repaired disk permissions. I did that, and according to Disk utility everything went rather swimmingly. However, that didn't fix anything,in fact, it made things slightly worse. Ever since I reset disk permissions, everytime I open Safari, it freezes immediately, and that has only happened since I repaired disk permissions. My home page is about:blank, if anyone was wondering. I've only discovered this happening with Safari as of now. I switched Chrome as my primary web browser for now.

    Being the resourceful person I am, I tried to isolate the problem. My sister, luckily, has an identical MBP. First, using target disk on my computer, I booted my SSD onto her computer - this is to see if the problem was HDD/SSD related or motherboard related. When I booted my SSD onto her computer the same problems occurred: Safari froze upon start up, and then computer would hard freeze after about two hours. However, when I booted her HDD onto my computer via target disk, there were no problems. Safari opened just fine and I used her computer for several hours without issue.

    At this point, I was pretty sure it was the SSD, but I thought it was possibly a bad Sata cable or something. But nope. Last night, I switched harddrives completely. No target Disk. I put my SSD in her computer and put her HDD in my computer. I got the same results as target disk. It can't be the motherboard or memory, because both computers worked fine with my sisters harddrive. Only the computer booted off of the SSD would have these problems.

    At this point I think it could be two possibilities
    A) Either the SSD itself is starting to become defective
    B) Some software component of my SSD is buggy

    I think it could be something software related because why would Safari and safari only freeze after launch, but no other apps? Also something of note, these problems were happening, I tried to see if doing anything with software update would help, updated everything that needed to be updated, and these problems still occurred.

    What do you guys think? anyone have an idea of what it could be? Any suggestions of how I handle this? Applecare is expired. I'm considering doing a clean install but I'm not fully backed up yet and I don't want to waste my time and have it not work. But I also don't want to buy a new hard drive or SSD and have it do the same things. And I'm not getting a new computer if the only problem with it is contained within the storage unit, whether that problem is within the software or hardware related.

    Responses and suggestions would be highly appreciated, thanks.

    EDIT: this information may be of interest: currently have 19.51 GB of available space (out of 256 GB). At one point, about a month and a half or so ago, my storage was as low as 9 or so GB free.

    I am running OSX 10.6.8
     
  2. duervo macrumors 68000

    duervo

    Joined:
    Feb 5, 2011
    #3
    Since you've already determined that the problem follows the drive, logic suggests that it's the drive.

    - Update firmware on SSD if there's one available for it.
    - If firmware update is not available, or doesn't fix it, then RMA the SSD drive and get a replacement or buy a new one.
    - You can also try wiping the drive and reinstalling OS X from scratch, but I suspect it's either firmware or drive problem since it locked up running AHT too.
     
  3. Maserati7200 thread starter macrumors 6502a

    Maserati7200

    Joined:
    Mar 17, 2009
    Location:
    11230, Midwood, Brooklyn, NY, USA, North America
    #4
    Bingo! the firmware update worked perfectly! Backed up my drive before the update just in case the firmware update would have corrupted something, but thankfully it didn't. Took a few days to back up the important stuff of my drive because I had to do it incrementally (as my computer would keep freezing).

    Thank you so much for suggesting that, really very helpful! I never would have thought of that. If you didn't suggest that I would've ended up doing a clean install only for it to not work. THANKS AGAIN!! :):D
     

Share This Page