Mid 2010 Macbook Pro Won't Sleep on Power Adapter

capitanbuzo

macrumors 65816
Original poster
Jul 17, 2007
1,117
132
I have a Mid 2010 edition Macbook Pro running Lion and I recently noticed that it will not sleep if I close the lid or select sleep from the Apple icon if it is connected to the power adapter but it sleeps fine (using the sleep light as an indicator) while on battery power or I put it asleep on battery power and then reconnect the power adapter. Also, at times, when I open the lid (never having gone to sleep), the screen comes on and then turns off after 5-10 seconds. Any ideas?
 

GGJstudios

macrumors Westmere
May 16, 2008
44,436
800
I have a Mid 2010 edition Macbook Pro running Lion and I recently noticed that it will not sleep if I close the lid or select sleep from the Apple icon if it is connected to the power adapter but it sleeps fine (using the sleep light as an indicator) while on battery power or I put it asleep on battery power and then reconnect the power adapter. Also, at times, when I open the lid (never having gone to sleep), the screen comes on and then turns off after 5-10 seconds. Any ideas?
Running on AC power or battery shouldn't affect the ability to sleep, unless you have different settings in the Energy Saver profiles.

Mac OS X: Why your Mac might not sleep or stay in sleep mode
Determine why your Mac wakes up from sleep
 

capitanbuzo

macrumors 65816
Original poster
Jul 17, 2007
1,117
132

esadb

macrumors 65816
Nov 29, 2008
1,184
0
I got the exact same issue and just noticed this.

If I unplug power adapter, it goes to sleep. I checked the settings, even rebooted the mac - still same issue.
Running latest Lion release.
Only my is a late 09 macbook.

Will try a disk repair&permissions.
 

esadb

macrumors 65816
Nov 29, 2008
1,184
0
Fixed..

Go into your prefs - turn on all sharing options - reboot - come back and disable them.

Close your lid - mac should be sleeping now.

No idea why this was an issue but it fixed it for me after I read about it online as some people suggested. good luck
 

capitanbuzo

macrumors 65816
Original poster
Jul 17, 2007
1,117
132
Fixed..

Go into your prefs - turn on all sharing options - reboot - come back and disable them.

Close your lid - mac should be sleeping now.

No idea why this was an issue but it fixed it for me after I read about it online as some people suggested. good luck
Thanks a lot man! That did the trick! How weird of an issue though.
 

The Bomb

macrumors newbie
Feb 13, 2013
1
0
For anyone having the same problem, it seems to be an issue with Internet sharing. So turn that off, and you should be golden :) .
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.