Mid 2010 MBP - youtube = lagg out

Discussion in 'MacBook Pro' started by hawaiiankanak, May 26, 2012.

  1. hawaiiankanak macrumors newbie

    Joined:
    May 26, 2012
    #1
    Hey everyone,
    So for a couple months now I noticed that when ever I would try load a youtube video, my Macbook Pro would always lagg out in intervals.

    Example:
    Videos loading, sound plays, no animation to video, video speeds up, try to stop video, pin wheel (beach ball), video stops, sound continues for like 6 seconds, videos stops playing.

    During that time the video is buffering/loading, I pin wheel if I try to minimize the window, change the volume, start another app.

    I see this most noticeably when im trying to youtube (Watch).
    Any help would be most appreciated

    MBP
    15 inch 2.5GHZ Intel Core i5
    4GB 1056 MHz DDR3
    320GB HD
     
  2. miles01110 macrumors Core

    miles01110

    Joined:
    Jul 24, 2006
    Location:
    The Ivory Tower (I'm not coming down)
    #2
    Try a different browser to see if it still happens.
     
  3. Slinkwyde, May 26, 2012
    Last edited: May 26, 2012

    Slinkwyde macrumors regular

    Joined:
    Jan 26, 2012
    #3
    Yeah, try Chrome which is a very fast browser. Or for Safari, try the ClickToFlash extension ("Safari" menu -> "Safari Extensions"), which replaces Flash video with native H.264 MP4s whenever possible, for many different sites.

    YouTube also has an opt-in HTML5 beta.

    Update your Flash plugin if needed.

    More RAM would also help, but try the above first. What OS version and browser do you use?
     
  4. hawaiiankanak thread starter macrumors newbie

    Joined:
    May 26, 2012
    #4
    Ill try the above and see how it goes.

    My OS is: 10.7.4 (Upgraded to Lion a while ago but I just re-installed with a backup but not sure if that backup had lion on it)

    I use the Safari Browser.

    I will try those extensions and if no go, then Ill just switch to chrome.

    Thanks guys
     
  5. diamond3 macrumors 6502a

    Joined:
    Oct 6, 2005
    #5
    I'm not sure if you have it installed, but I continually have problems with Perian. It would show up in your sys pref window if you do. Disable/uninstall it and try it.
     
  6. Slinkwyde macrumors regular

    Joined:
    Jan 26, 2012
    #6
    Perian is a QuickTime plugin. It doesn't affect the standard YouTube player, which is Flash. It could have an effect on my ClickToFlash and HTML5 beta suggestions, which in Safari would use QuickTime. .

    I don't recall Perian ever giving me any trouble, but I'm still on Snow Leopard.
     
  7. iZac macrumors 68000

    iZac

    Joined:
    Apr 28, 2003
    Location:
    Shanghai
    #7
    Different machine, but I get the same problem, youtubes flash content sometimes hangs up safari totally until the video is totally loaded, then breaths a sigh of relief.
     

Share This Page