Mid 2011 Mac Mini boot loop

Discussion in 'Mac mini' started by rpsibewl110, May 6, 2019.

  1. rpsibewl110, May 6, 2019
    Last edited: May 7, 2019

    rpsibewl110 macrumors newbie

    rpsibewl110

    Joined:
    May 5, 2019
    Location:
    Mesa, AZ
    #1
    Hello all

    I did do a search for boot up loop and found nothing that helped. I was given a mid-2011 mac mini that is stuck in a boot up loop.

    1. I have tried an external hard drive with a compatible OS.
    2. Tried a flash drive with install software with Lion then El Capitan
    3. moving the ram around and trying one at a time and in different slots.
    4. pulled the hard drive installed a different one I had just used to boot a laptop. It was at the beginning of a fresh install so I completed it and put it back into the mini.
    5. put the HD from the Mini into the external case and booted the laptop.
    6. tried a flash drive with Ubuntu and it would load the menu I can select an option then blank screen and it would go no further.
    7. I can leave it at the option screen when selecting a bootable drive for as long as I would like without rebooting.
    8. found a line using command v that says previous shutdown cause -128 userCanceledErr User canceled an operation
    9. Airport: Link up on en1
    got incomplete channel sequence length 0 should be 16
    en1: bssid changed to f8:1e:df:f8:c4:0b
    en1: channel changed to 2
    en1: 1080211 interface:: Postmessage bssid changed
    Unexpected payload found for message 9, dataLen 0
    These are the last lines now that the OS is finished installing and setup.

    So I can figure that the hard drive and ram are good. it's not an overheating thing because it does it right away even after sitting until completely cool. I even put ice packs on top and bottom to check.

    I am thinking hardware issue but not sure where to look from here. My only thought might be the wifi/bluetooth card has failed. I plugged in a network cable and the wifi still looks as if it has failed but the last lines are the 1gig network up on en0.

    EDIT: I did try safe boot also and it does not work either.

    I have a video of the bootup using command v.

    Any help would be appreciated
     
  2. rpsibewl110 thread starter macrumors newbie

    rpsibewl110

    Joined:
    May 5, 2019
    Location:
    Mesa, AZ
    #2
    Since posting I have started up in internet hardware test and all checked out good. Then hooked it up in target disk mode wiped the drive and then booted install USB and it still only boots part way then loops.
     
  3. cococheaf macrumors demi-god

    cococheaf

    Joined:
    Jul 10, 2018
    Location:
    Austria - Lake of Constance
    #3
    At first i would unplug all external devices, such as LAN, USB, audio, etc., only leaving the keyboard plugged in.
    Then do a smc reset, folled by a 3-way PRAM reset (keep holding alt+cmd+P+R until it pings 3 times). At the second of the 3rd beep, keep holding ctrl+shift to start macos in safe mode. See what happens then. Good Luck.
     
  4. rpsibewl110, May 8, 2019
    Last edited: May 8, 2019

    rpsibewl110 thread starter macrumors newbie

    rpsibewl110

    Joined:
    May 5, 2019
    Location:
    Mesa, AZ
    #4
    I forgot to include that in the first post. But What I did was since the drive was wiped I used TDM on it and attached it to my Mac Pro. I used superduper to clone/backup my mac pro to it (El Capitan) and then booted the mac pro from the mac mini to make sure the drive is bootable. I unplugged the mini and moved it to its station to work on it. Hooked up waited a few seconds and hit the power button this should have reset the SMC. Tried to boot normal and it looped, rebooted by unplugging and hit the power button then I hit the alt,cmd,p,r buttons on the keyboard waited for the tones and then hit the shift key for safe mode. Loading screen came up and the bar moved to about the same place as always before looping but instead of looping it staying at a white screen where it's sitting now waiting to see if it's just running very slow.

    EDIT: Tried to boot into recovery mode it went to the internet, picked the wifi and it started to load. The bar counted down with spinning globe and the went to an apple screen with spinning circular lines or bar then reboots to the white screen and sits there.

    EDIT: Starting it in verbose mode and the last line that shows on the screen is "en2: promiscuous mode enable succeeded" Looking at my laptop there are only 5 lines after that so it's very close to booting but just not making it.
     
  5. now i see it macrumors 68040

    Joined:
    Jan 2, 2002
    #5
    If it won't boot off an external drive, chances are high it's toast. My 2007 mini eventually bit the dust. These things don't last forever.
     
  6. haralds macrumors 6502a

    haralds

    Joined:
    Jan 3, 2014
    Location:
    Silicon Valley, CA
    #6
    My mid 2011 just lost the BIOS battery after 8 years. It had odd boot behavior and then stopped altogether. No chime - just a quick white flash. Replacing the battery is a bit of a PITA - look at iFixIt.
    But with a new 2032 it is running nicely again.
     
  7. rpsibewl110 thread starter macrumors newbie

    rpsibewl110

    Joined:
    May 5, 2019
    Location:
    Mesa, AZ
    #7
    The battery has 3v so it's good. I have done many other tests and replaced some parts like the ram and hard drive and removed the wifi card and it still loops. I m to the point where I believe it to be a power supply or mainboard. I'm not forking over $145 for a power supply when I think it's the mainboard. Thanks for the comments.
     

Share This Page

6 May 6, 2019