mid 2012 13" Can't format SSD, Can't install Yosemite on HDD

Discussion in 'MacBook Pro' started by DebianJunkie, Apr 2, 2015.

  1. DebianJunkie, Apr 2, 2015
    Last edited: Apr 2, 2015

    DebianJunkie macrumors newbie

    Joined:
    Feb 25, 2015
    #1
    I've got MacBookPro9,1 Mid 2012 13"
    At first I thought that the HDD is bad but I tested it on another PC and the SMART is ok, data can be written and read from file systems on the disk.

    Also posted this in similar thread, though I have problems with HDD, too.:
    http://forums.macrumors.com/showthread.php?t=1849439

    The funny thing is if I boot Ubuntu from USB flash drive (just copy the contents of ubuntu.iso to a partition on a usb flash drive formated with MBR (haven't tested guid but probably also works) partition table and file system fat32 (vfat in linux) I can partition the ssd disk with GUID partition table, make file systems, write raw data with dd to disk directly or to a filesystem like this

    (WARNING commands below WILL DESTROY data on your ssd or other drive found as /dev/sda)

    dd if=/dev/zero of=/dev/sda bs=4096 count=100000

    or with a file system:

    /dev/sda1 is mounted on /mnt/sda1 as hfsplus

    dd if=/dev/zero of=/mnt/sda1 bs=4096 count=100000

    I checked what it had written and the zeroed files are there. Also if I create a partition table (guid) and format the partition w/ hfsplus Yosemite installer sees it but the installation cannot start copying files (the installation stops (but not freezees) on like 20 minutes remaining and thats so for hours)

    If I put back hdd which stopped booting into Mavericks/Yosemite (not sure which was there previously) I can freely partition or format but Yosemite stops (but not hangs) on some 20 minutes left and stays there forever, logs say that it can't copy the 2nd .pkg file even though the usb installer drive has the .pkg and I even tried a different usb drive- the same. USB installer works with other macs.
    Mavericks on the other hand proceeds to install and then stops on 1 minute remaining and stays there. Log file is no help. And doesn't boot later.- The grey question mark.

    I suspect it's the firmware (EFI or SMC) The HDD smart is ok and the ssd is brand new.
    My firmware/smc:
    MBP91.00D3.B08
    2.2f41

    Edit: Figured I can Install Yosemite on external drive and then upgrade SMC firmware from within that working OS. Not sure how to or where to get SMC and FW DOWNgrades though.
    Will report back tomorrow.
     
  2. DebianJunkie thread starter macrumors newbie

    Joined:
    Feb 25, 2015
    #2
    Resolved?

    Well, well, well. Took me a whole night but finally getting somewhere :)
    I installed Mavericks onto a USB hdd and it went without a hitch. I only noticed it was Maverics after I booted into it. Ah well. I forgot I was trying both versions and that Mavericks was the last to try. Anyways.

    1) The wireless card did NOT connect to my AP (kept saying wrong password even though I double checked the pw)
    2) Through ethernet I updated smc but that didn't help.
    3) Booted into Ubuntu 14.04 and with some broadcom driver fiddling was able to test the wireless which worked good (so no hw or password problems)
    4) with dd cloned my usb install partition to internal hdd partition as Disk Util hanged on Restoring one partition to another (tried that by booting mavericks installer up)
    Warning. Will DRESTOY DATA on your internal disk 2nd partition!
    under ubuntu to clone the system partition:

    dd if=/dev/sdc2 of=/dev/sda2 bs=4096 & pid=$!

    5) upon restarting from Internal hdd got stuck on spinning wheel. Decided to reset P ram
    (press and hold Command+Option + P + R, then turn MBP on, wait for it to chime the 2nd time and then release the keys)
    and hit command+V for verbose commandline output (hoping to see error messages) To my surprise it booted up too quickly to even notice error messages.

    I thought I had already reset pram but maybe not. On Monday or Tuesday Ill try cloning the hdd partition onto an ssd and see if it boots. Also will try Yosemite install on hdd and ssd and report back.
     

Share This Page