Mid-2015 2.8Ghz MBP Benchmarks

Discussion in 'MacBook Pro' started by Kestrel452, Nov 3, 2015.

  1. Kestrel452 macrumors regular

    Joined:
    Jul 23, 2008
    #1
    Hey guys,

    I'm having trouble running X-Plane 10 on my Mid-2015 15" MBP. It has the upclocked 2.8 Ghz and R9 M370X dGPU.

    Even at the "medium" pre-set for X-Plane 10's rendering options, it runs with a bit of lag. Strangely the FPS hovers around 25-31, but clicking a button in the cockpit (or even the XPlane menu) there's usually a 2-3 second lag before it reacts.

    I've run a Geekbench 3 test of the computer here: http://browser.primatelabs.com/geekbench3/4069972

    Also ran Unigine Heaven on "extreme"; only change was changing the rez to 1440x900: http://i.imgur.com/acJHIVY.png

    Can any knowledgeable members here find something amiss in that benchtest? I can't really believe that this computer wouldn't run XPlane 10 on medium...
     
  2. cbautis2 macrumors 6502a

    Joined:
    Aug 17, 2013
    #2
    Bootcamp Windoze and you'll get excellent gaming performance.
     
  3. Samuelsan2001 macrumors 604

    Joined:
    Oct 24, 2013
    #3
    This is the recomended system requirements from the Xplane 10 website

    • a Quad Core, 3.0 GHz or faster processor,
    • 16-20 GB of RAM,
    • a DVD-ROM, and
    • a high-performance, DirectX 11-capable video card with at least 4 GB of on-board, dedicated VRAM.
    As you can see to get the best out of it you need a powerful desktop GPU it's that simple.
     

Share This Page