MIDI Issues in Lion

Discussion in 'Digital Audio' started by MacFunk, Jul 25, 2011.

  1. MacFunk macrumors newbie

    Jul 25, 2011
    Since upgrading to Lion the other day, I have been having a few issues with MIDI.

    I first noticed a problem when I tried exporting a MIDI file from a programme i use called GuitarPro 5. With Snow Leopard, once I clicked on the button to export the song in MIDI, the item would turn up on my desktop or wherever I saved it to. When I tried exporting a song (and eventually many tries) to MIDI and on to my desktop since having Lion, it just simply didn't turn up. I did also try saving it to a different destination to the desktop just to see if it worked. I also, made sure the file name had .mid after it just incase that was the issue, but it didn't make a difference. I understand this might be an issue with the programme running on the newly released Lion, and might be a bug in the softwares part.

    Are there any known issues with MIDI in Lion?. As I also noticed after a few minutes that MIDI files in general are A LOT quieter in volume since having lion. This includes raw MIDI being played back in a variety of programmes. This suggests to me it might be to do with Lion as a whole, as opposed to my programme exclusively.

    If anyone has had similar experiences or can offer a clue as to what might be going on, that would be great as I am keen to keep making music but would rather not have to downgrade back to SL if possible.

  2. LeakedDave macrumors regular

    Jun 26, 2011
    Midi issues here. Can't hear all my old compositions for ****. Pissed off. WTF?
  3. protools-user macrumors newbie

    Oct 28, 2011
    Recently update to new MBP with lion. MIDI was working for a few weeks but lately was receiving mac os x MIDI driver errors. Logic, Reason and even garage band refused to launch. Solution I used is delete the content in MIDI drivers folder. Macintosh HD>Library>Audio>Midi Drivers. This is of course after archiving contents to desktop. Have not tested a midi controller yet but programs are launching with no issue.
  4. shaketheclouds macrumors newbie

    Jul 24, 2011
    I've just encountered this issue on a new macbook with OSX Lion.

    my previous macbook with GuitarPro5 never had these issues, but now cant export to MIDI.

    looked around and posted on the arobas software forum, but no luck.

    original poster or any one else have any luck?

    there is literally nothing in my macHD > library > audio > MIDI xyz folders. fresh OSX lion install.
  5. Soulfire macrumors newbie

    Jan 8, 2012
    Same issue here. Additionally, all my sounds from the RSE soundbank have disappeared. Do you guys have the same issue?
  6. nweash macrumors newbie

    Dec 28, 2008
    bumping this for the same issue, also all my instrument names show up blank. the numbers are there but for the names of each patch its just a - next to the number.
  7. drawnacrol macrumors newbie

    Sep 23, 2009
    Does anyone have a fix for this problem, its really annoying,

Share This Page