Midi sustain pedal keeps down

Discussion in 'Digital Audio' started by solfinker, May 10, 2017.

  1. solfinker, May 10, 2017
    Last edited: May 10, 2017

    solfinker macrumors newbie

    Joined:
    Oct 5, 2015
    #1
    In GarageBand when you use the sustain pedal it keeps using it when you release, unless you make some fast releases. It looks like a mechanical problem, but it's not, because the piano itself doesn't behave like that.

    Btw, my keyboard is a Yamaha Arius YDP 162.
    Is it a bug to fix or have I setup the wrong functioning?

    Thank you
     
  2. keysofanxiety, May 10, 2017
    Last edited: May 10, 2017

    keysofanxiety macrumors 604

    keysofanxiety

    Joined:
    Nov 23, 2011
    #2
    I had a similar issue on my KORG TR-76; it would sustain when released and not sustain when pressed. Basically there should be a setting somewhere on your keyboard to reverse the polarity of the damper pedal.

    My one was some Roland pedal though the issue also persisted with a Yamaha pedal. Seems a lot of the pedals don't have standardised polarity (e.g., 0 is up, 1 is down).

    I had a quick flick through the manual for your keyboard but couldn't find anything obvious... however there definitely will be a setting there. :)

    EDIT: Sorry I misunderstood your original post, you just edited it to say the problem only persists in GarageBand. Does the issue persist in other DAWs? What about through different effects?
     
  3. fastlanephil macrumors 6502a

    fastlanephil

    Joined:
    Nov 17, 2007
    #3
    I think I remember having that issue with my Yamaha digital piano and DAW a long time ago. I don't remember a solution beyond maybe turning the piano on and off. I wonder if your piano is transmitting two channels over USB if it's set to play two internal sounds at once which it can do. Usually that can create recorded double MIDI notes in the piano roll. You might check to make sure you're only transmitting one MIDI channel into GB by making sure your piano is set to play only one voice and not split voices.
     
  4. solfinker thread starter macrumors newbie

    Joined:
    Oct 5, 2015
    #4
    If I turn the piano off and on, the problem persists.
    Nevertheless if I open a new file in GarageBand the problems disappears.
     
  5. solfinker thread starter macrumors newbie

    Joined:
    Oct 5, 2015
    #5
    No. Today it is not working this way. It's not working either way. In sum, it's not working at all.
     

Share This Page