might have spoke too soon MBP 15 2.2 issues

Discussion in 'MacBook Pro' started by darqueside, Mar 9, 2011.

  1. darqueside, Mar 9, 2011
    Last edited: Mar 9, 2011

    darqueside macrumors newbie

    Joined:
    Mar 2, 2011
    #1
    I will preface this by saying my MBP has been working flawlessly until now...

    Downloaded todays updates etc installed them and restarted. Everything seemed fine till I tried to open something, beachball instantly which isnt charateristic of this machine waited a second didnt change, cursor still moving but cant access anything waited some more, still nothing had to power button restart, tried once more same deal. Comming from PC land I tried to start it in safemode which according to apple support site does a bunch of other stuff that may fix the problem did that seemed to do its thing for bit got to desktop then restarted, now it just goes to apple screen spins for a bit and shuts down. Used disk utility Cd wont even complete disk repair just halts, tells me I need to reformat and reinstall. Which I am doing but should I even bother reinstalling any apps and just take it back for a new one its brand new and crap like this shouldnt be happening. I know I am pretty much an apple noob and perhaps may have done something wrong but I am pretty sure this isnt normal right ?

    oh
    I7 2.2 750gb hd standard res only thing not stock is 8gb gskill ram but that has worked fine for almost a week now
     
  2. Apple Corps macrumors 68030

    Joined:
    Apr 26, 2003
    Location:
    California
  3. kobyh15 macrumors 6502a

    Joined:
    Jan 29, 2011
    #3
    Did you swap your stock RAM back in just to check? May be worth trying.
     
  4. vincenz macrumors 601

    vincenz

    Joined:
    Oct 20, 2008
    #4
    Doesn't sound right. It may be that RAM acting up. Swap it back out and do some more tests.
     
  5. SPEEDwithJJ macrumors 65816

    SPEEDwithJJ

    Joined:
    Nov 2, 2008
    #5
    Bring your MBP back for an exchange. Good luck. :)
     
  6. darqueside thread starter macrumors newbie

    Joined:
    Mar 2, 2011
    #6
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

    Would the ram really cause my hd to not pass the verify stage of disk utility even. In my experience ram going bad usually doesn't even let you go that far, it usually won't let you even post if it's bad, swapped it out anyway still a no go. It seemed to be working after I reformatted and it passed disk check even with the gskill ram in it and after os reinstall seemed to boot to the welcome screen just fine with either set of ram so it's def going back.
     

Share This Page