Mighty Mouse pointer no longer working

Discussion in 'MacBook' started by sfrost12, May 6, 2009.

  1. sfrost12 macrumors newbie

    Joined:
    May 6, 2009
    #1
    I've been using my M Mouse successfully with my MacBook until recently when the Mouse Pointer no longer moves. The button does engage the dashboard and if I position the cursor using the MacBook trackpad, then the click function of the mouse does work. I have tried changing the batteries. It appears I am having a similar problem when I use a wired mouse. Just in case it's connected, I run Parallels and did recently upgrade Windows software. Any ideas? Thanks for any suggestions!
     
  2. Insulin Junkie macrumors 65816

    Insulin Junkie

    Joined:
    May 5, 2008
    Location:
    Mainland Europe
    #2
    Did the problem start occuring at the same time you ran windows on your mac through Parallels? Does the mouse only behave this way on windows?

    Since both mice display the same behaviour It's most probably not a problem with the mighty mouse itsself (though ordinarily I wouldn't put it past it, in my opinion the MM is a pretty bad piece of hardware). Have you installed all the windows drivers & updated them properly?
     

Share This Page