Mighty Mouse Problem

Discussion in 'Mac Accessories' started by Chris 123, Dec 19, 2008.

  1. Chris 123 macrumors regular

    Chris 123

    Joined:
    Jun 28, 2008
    Location:
    U.S. (New England)
    #1
    I have had my mighty mouse for a couple months and it has worked great on my macbook. Just recently the middle button won't open up the dashboard and the two side buttons go through spaces instead of exposing all windows. In system proferences under mouse and spaces both are set for the middle button to open the dashboard and the side buttons to expose all windows but they don't do that. It could be an easy fix but I don't know what else to try?
     
  2. Chris 123 thread starter macrumors regular

    Chris 123

    Joined:
    Jun 28, 2008
    Location:
    U.S. (New England)
  3. iknowyourider macrumors 6502a

    iknowyourider

    Joined:
    Mar 26, 2008
    Location:
    onanorthboundtrain
    #3
    Never heard of that. They should replace it for you if it's bad. Have a credit card ready incase they want yours back. They will send you a new mouse and you send yours back in the same box and your card will not be charged. I have heard of people getting new ones and apple didn't want the other back. I think those days are about gone though.
     
  4. Chris 123 thread starter macrumors regular

    Chris 123

    Joined:
    Jun 28, 2008
    Location:
    U.S. (New England)
  5. Chris 123 thread starter macrumors regular

    Chris 123

    Joined:
    Jun 28, 2008
    Location:
    U.S. (New England)
    #5
    I figured out the two buttons are working and the settings in system preferences are correct (side buttons expose and top button dashboard) but they still do not work. The middle button does this weird thing where if you press it and drag the mouse down it will scroll and the side buttons just don't do anything. I have also noticed that with the mouse I cannot change the scrolling speed with the scroll ball on any app, scrolling is always really fast.

    A new mighty mouse is not what I need because I tried my friends mighty mouse, which works on his, and I have the same problem with it on my computer.

    It has been like this for a long time and is really pissing me off. I don't think I downloaded any new apps at the time it stopped working but maybe I did. There must be some settings besides system pref. that would do this but I can't find them.

    Any help would be much appreciated.
     
  6. trip1ex macrumors 68000

    Joined:
    Jan 10, 2008
    #6
    There might be a preference file that got corrupted.

    I know your user/library/preferences folder has a system preferences plist file. Delete that and see if that helps.

    That's my only guess. Unless it's a hardware issue. Try a different usb port just in case.
     
  7. TenFour macrumors member

    Joined:
    Feb 12, 2006
    #7
    Fool-Proof solution for all Mighty Mouse problems:

    1. Melt Mighty Mouse

    2. Buy better mouse

    3. Enjoy better mouse
     
  8. Chris 123 thread starter macrumors regular

    Chris 123

    Joined:
    Jun 28, 2008
    Location:
    U.S. (New England)
    #8

    Thanks. I can't find the file in pref. do you know exactly what it's called. I can't try a diff. usb port b/c it's bluetooth.
     

Share This Page