miglia tvmax recording problem

Discussion in 'Mac Accessories' started by pumpkinwhite, Sep 28, 2006.

  1. pumpkinwhite macrumors member

    Sep 3, 2006
    I have a Miglia TVMax (with eyetv 2.3.1 software). There is a problem with its recording. Basically i kept getting a lot of 0 KB recordings. The recording counter would be stuck at 0 seconds. After a lot of effort i found the problem.

    It happens only when eyetv software is running and the computer goes to sleep. (software is open on the dock when the computer sleeps). when the scheduled time comes, it wakes the computer. if it is the first wake-up since the program has been started, it will record it properly. now if the computer sleeps again after recording, the second time when it wakes the computer, the recording will not take place.

    if i try the following steps this error happens -

    1. start eyetv. my option of 'open live tv window at startup' in preferences is off
    2. schedule a recording for few minutes hence.
    3. put computer to sleep.
    4. computer will wake up at the recording time. THIS TIME RECORDING
    5. now stop the recording.
    6. schedule another recording, for few minutes hence. DO NOT QUIT
    7. put the computer to sleep.
    8. again computer will wake up when recording time arrives.
    9. This time recording will not take place. the window will be stuck
    at "This channel is currently not available".

    so basically if i have 3 recordings scheduled in the night. say there
    is a gap of 30 minutes between them. The first recording will take
    place. then the computer goes to sleep automatically (i have sleep
    setup after 15 minutes of inactivity). when it wakes up for the next
    one, no recording takes place. and same for 3rd.

    also, the problem seems to be with the tuning. If i do this -

    1. start eyetv. put on the live tv window. let the channel be running.
    2. while live tv window is on, put the computer to sleep.
    3. wake computer by pressing any key.
    4. now the tuner tries to tune back the channel. it first says 'a moment please..' or something and then 'this channel is not currently available'.

    Anyone else having the same problem? Kindly help
  2. matthias67 macrumors newbie

    Oct 6, 2006
    unfortunately I do not have a solution. But I've exactly the same problem with my brand new mac mini (intel), miglia tvmax and eyetv 2.3.1. Multiple recording is only possible if sleep is deactivated.
    There is a open ticket at Elgato's support. But no reaction until now.
  3. matthias67 macrumors newbie

    Oct 6, 2006
    eyetv update


    Elgato's support seems to be aware of this issue. They provided an update 2.3.2 which is supposed to solve the problem. Indeed the behaviour now is different and at least the tuning problem seems to be solved. But I get still 0 byte records.
  4. Neddog macrumors newbie

    Nov 13, 2006
    I too have this same problem. Elgato's support (initially) was exceptional. They responded quickly, and were very attentive. They even had me send in the unit for replacement. However, I have now sent three messages to their tech support (they don't have a tech support phone number), and have gone nearly three weeks with no response.

    I fear this is a problem they can't solve and we won't hear from them until they've got a new version to fix it.

    I've tried everything and at this point, the only thing that helps is to make sure the computer never sleeps. Yeah, that's not such a great option, is it?
  5. pumpkinwhite thread starter macrumors member

    Sep 3, 2006
    I know this is a late post of an old topic. But yesterday i found a solution to the problem. Basically you take advantage of the fact that this problem never occurs if eyetv is quit at the time when computer goes to sleep.
    So you use a tool called SleepWatcher, which can run automatic scripts whenever the computer sleeps. I installed SleepWatcher and created a small script which quits eyetv (if it is running) everytime the computer goes to sleep. So whenever the computer auto-awakes for recording, eyetv has to launch again, and recording takes place perfectly!! No more 0KB recordings ever.

    I have posted detailed instructions in miglia forums. Go to user community forums at miglia website. In the forum 'TV Hardware' read my post (I use alias 'bengal tiger' there). You would have to register to view the forum. Hope this helps.

Share This Page