Migration Assistant can't migrate profile to new mac mini (Leon)

Discussion in 'Mac mini' started by buddd, Aug 8, 2011.

  1. buddd, Aug 8, 2011
    Last edited: Aug 8, 2011

    buddd macrumors newbie

    Joined:
    Jul 5, 2011
    #1
    Hi,

    I have a weird problem with new mac mini that I just received from Apple. I opened a case with their support, but frankly speaking they are pretty useless for now.

    Maybe somebody can help me here.

    I've reinstalled system on the new mac (needed a case sensitive fs), booted and trying to migrate my crap from the old one. I created a temporary account (test) on new mini, anyway migration assistant doesn't work. Both mini's have the same Leon, but the old one was upgraded from torrent version of Lion and it's up to date.

    See the pics attaches, there is a weird error about "existing account" on the new mac. Both pics are from new one. Obviously account names are different, and even if I'm trying to migrating during initial setup, where there are no accounts - it doesn't allow me, same error.

    The syslog.log from new mac, old one doesn't show anything interesting or unusual.

    Any ideas guys what's going on here or should I just give up and move my staff manually? Basically it's only reinstalling apps, but what the hell - it doesn't worth paying almost a gran and move staff manually, just like in Ubuntu.

    Code:
    Aug  8 19:30:10 test configd[14]: setting hostname to "test.local"
    Aug  8 19:30:12 test mDNSResponder[44]: User updated Computer Name from “test’s Mac mini” to “test”
    Aug  8 19:30:12 test mDNSResponder[44]: User updated Local Hostname from “tests-Mac-mini” to “test”
    Aug  8 19:30:25 test UserEventAgent[11]: ServermgrdRegistration cannot load config data
    Aug  8 19:30:25 test UserEventAgent[11]: ServermgrdRegistration oldConfig is nil during net changed notification
    Aug  8 19:30:27 test Migration Assistant[266]:   (SYS) We've received count = 0 systems
    Aug  8 19:30:31 test authexec[271]: executing /Applications/Utilities/Migration Assistant.app/Contents/Resources/MigrateTool
    Aug  8 19:30:31 test MigrateTool[271]: ------
    Aug  8 19:30:32 test Migration Assistant[266]:   (SYS) We've received count = 1 systems
    Aug  8 19:31:59 test helpd[203]: CarbonCore.framework, Our status with coreservicesd is unusual, 2, and things likely will stop working.
    Aug  8 19:31:59 test helpd[203]: CarbonCore.framework: Unable to connect to coreservicesd.  Things likely won't work.  Sorry.
    Aug  8 19:54:21 test [0x0-0x1b01b].com.apple.MigrateAssistant[266]: Will not set default: UID=0 does not own directory /Users/test
    Aug  8 19:54:37: --- last message repeated 2 times ---
    Aug  8 19:54:37 test MigrateTool[271]: (SFS) Activating SlingShotFS using /var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/T/sFSCache
    Aug  8 19:54:37 test [0x0-0x1b01b].com.apple.MigrateAssistant[266]: 2011-08-08 19:54:37.463 MigrateTool[271:620b] (SFS) Activating SlingShotFS using /var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/T/sFSCache
    Aug  8 19:54:37 test [0x0-0x1b01b].com.apple.MigrateAssistant[266]: Will not set default: UID=0 does not own directory /Users/test
    Aug  8 19:55:06: --- last message repeated 1 time ---
    Aug  8 19:55:06 test com.apple.launchd.peruser.501[170] (0x7fd77b900ed0.anonymous.screencapture[290]): The following job tried to hijack the service "com.apple.screencapture.interactive" from this job: 0x7fd77a401fc0.anonymous.screencapture
    Aug  8 19:55:06 test com.apple.SystemUIServer.agent[187]: screencapture: cannot run two interactive screen captures at a time
    Aug  8 19:55:46 test Migration Assistant[266]: User C29D1C53-38EE-4535-8AFF-9AE7F47C5D32 weight now available.
    Aug  8 19:55:46 test Migration Assistant[266]: *** Assertion failure in -[SMSystem_SlingShot pathAnalysis], /SourceCache/SystemMigration/SystemMigration-491/SMFramework/SMSystem_SlingShot.m:358
    Aug  8 19:55:46 test Migration Assistant[266]: pathAnalysis called from UI
    Aug  8 19:55:47 test Migration Assistant[266]: (
                    0   CoreFoundation                      0x00007fff8ebe0986 __exceptionPreprocess + 198
                    1   libobjc.A.dylib                     0x00007fff8cd44d5e objc_exception_throw + 43
                    2   CoreFoundation                      0x00007fff8ebe07ba +[NSException raise:format:arguments:] + 106
                    3   Foundation                          0x00007fff9360514f -[NSAssertionHandler handleFailureInMethod:object:file:lineNumber:description:] + 169
                    4   SystemMigration                     0x0000000107e82e5a -[SMSystem_SlingShot pathAnalysis] + 123
                    5   SystemMigration                     0x0000000107e340e0 -[SMUser _sizeForSubPath:] + 120
                    6   SystemMigration                     0x0000000107e34059 -[SMUser sizeForSubPath:] + 102
                    7   SystemMigration                     0x0000000107e6f5b6 -[SMTree _editUser::] + 174
                    8   SystemMigration                     0x0000000107e6f221 -[SMTree userSizeInfoUpdated:] + 257
                    9   Foundation                          0x00007fff93557bed __-[NSDistributedNotificationCenter addObserver:selector:name:object:suspensionBehavior:]_block_invoke_1 + 47
                    10  CoreFoundation                      0x00007fff8ebc3b77 ____CFXNotificationPostToken_block_invoke_1 + 311
                    11  CoreFoundation                      0x00007fff8eb95b5c __CFRUNLOOP_IS_CALLING_OUT_TO_A_BLOCK__ + 12
                    12  CoreFoundation                      0x00007fff8eb4dc52 __CFRunLoopDoBlocks + 322
                    13  CoreFoundation                      0x00007fff8eb75d37 __CFRunLoopRun + 2023
                    14  CoreFoundation                      0x00007fff8eb75216 CFRunLoopRunSpecific + 230
                    15  HIToolbox                           0x00007fff8e7804ff RunCurrentEventLoopInMode + 277
                    16  HIToolbox                           0x00007fff8e787c21 ReceiveNextEventCommon + 355
                    17  HIToolbox                           0x00007fff8e787aae BlockUntilNextEventMatchingListInMode + 62
                    18  AppKit                              0x00007fff89492fc5 _DPSNextEvent + 659
                    19  AppKit                              0x00007fff894928c9 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135
                    20  AppKit                              0x00007fff8948f20a -[NSApplication run] + 463
                    21  AppKit                              0x00007fff8970d35e NSApplicationMain + 867
                    22  Migration Assistant                 0x0000000107e15094 Migration Assistant + 4244
            )
    Aug  8 19:58:55 test PubSubAgent[294]: SQL Error: SQLITE_CANTOPEN[14.0]: Database file not found
    Aug  8 20:00:15 test login[308]: USER_PROCESS: 308 ttys000
     

    Attached Files:

  2. indg macrumors 6502

    Joined:
    Feb 7, 2007
    #2
    looks like an ownership or permissions problem on /Users/test
    Code:
    Aug  8 19:54:21 test [0x0-0x1b01b].com.apple.MigrateAssistant[266]: Will not set default: UID=0 does not own directory /Users/test
    
    maybe user "test" doesn't have administrator privileges? have you tried repairing permissions?

    are you using migration assistant with the old mini in target disk mode? if not, try that:
    http://forums.macrumors.com/showpost.php?p=13084584&postcount=2

    make sure the username you're logged into is a different name than the user you want to bring over from the old mini.

    just curious, why do you need a case-sensitive fs?
     
  3. buddd thread starter macrumors newbie

    Joined:
    Jul 5, 2011
    #3
    Yes, I saw that error as well. User test has admin privileges and it's only one, brand new user on new computer.

    Usernames are different - I created "test" specifically for this purpose.

    Target disk won't work, I don't have cable.

    And the last one, I just got used to it, plus do some web-development.
     
  4. indg macrumors 6502

    Joined:
    Feb 7, 2007
    #4
    if you don't have a specific need for case-sensitive fs, you probably shouldn't use it. but i don't know what aspect of web development would require it.

    so you're migrating over ethernet? that's going to be slow. definitely use firewire if you can.

    you can also restore from an external backup drive or time machine drive via usb as well. have you tried that?
     
  5. buddd thread starter macrumors newbie

    Joined:
    Jul 5, 2011
    #5
    All my servers, workstations are case sensitive - so the desktop should be as well.

    Ethernet is not going to be slow, its 1GigE link.

    Restore from external backup doesn't work, new mac complains about "different hardware that you made your backup for", something like that.
     
  6. indg macrumors 6502

    Joined:
    Feb 7, 2007
    #6
    it may be gigabit ethernet, but migration assistant over it was dog slow for me. like 5-6MB/s. i tried it when migrating from a 2007 imac to 2010 mini and it took 2 hours to migrate what firewire400 did in about 30 minutes. perhaps it's improved in lion, but i doubt it.

    use migration assistant to migrate from a time machine backup or external clone/backup drive. not time machine restore.
    [​IMG]
     
  7. buddd thread starter macrumors newbie

    Joined:
    Jul 5, 2011
    #7
    That wouldn't be a problem, even if it's relatively slow. I'd just leave it for a night.

    Migration from backup volume fails, same error. The logs are clean however this time.

    I also did permission restore in Disk Utility, it fixed some folders like cache or something, not very related to home folder or anything like that.

    Any other ides? :)
     
  8. indg macrumors 6502

    Joined:
    Feb 7, 2007
    #8
    i'm reaching here, but the only other thing i can think of is a problem with ACLs. here's a tool you can use to remove them:
    http://nomulous.com/goodies/ACLr8/

    and you repaired permissions on the old mac that you're migrating from?

    now i'm really grasping at straws here:
    open /System/Library/CoreServices/Directory\ Utility.app
    go to Edit -> Enable Root User . it's most likely already enabled if you're using the only admin account. don't know if that would have anything to do with the "UID=0 does not own directory" error.
     
  9. Mak47 macrumors 6502a

    Joined:
    Mar 27, 2011
    Location:
    Harrisburg, PA
    #9
    I think this may be the same problem I had, but I'm not entirely sure.

    After I migrated my information over, nothing was able to be seen on the new system. I called Apple, and they had no idea what was wrong.

    I was afraid I was in for a major headache, but I looked around for a bit and found this:

    In the finder:

    devices>
    "your new mini">
    server HD(unless you renamed it)>
    users>
    Here you will find your old user information. Migration Assistant has moved it, but all the folders are locked and your new username doesn't have permission to access them.

    I just had to "Get Info" on each folder and give my new username permission to access the folders, then drag them to where I wanted them on the new machine.

    Like I said, your problem sounds like mine, maybe it isn't. Did I truly solve the problem? No, but this workaround was a lot easier than waiting days or weeks for a proper solution.

    Depending on how many folders you have migrated over, this may not be as easy for you, but hopefully this was some help.
     
  10. buddd thread starter macrumors newbie

    Joined:
    Jul 5, 2011
    #10
    No, on mine nothing is locked, I can open any folders.
     
  11. buddd, Aug 9, 2011
    Last edited: Aug 9, 2011

    buddd thread starter macrumors newbie

    Joined:
    Jul 5, 2011
    #11
    Thanks for suggestion, but running mentioned script is probably not the best idea, taking into account how license described there.

    I enabled root user in the directory (and yes, probably it was enabled), nothing changed.

    Good news! Apple has left voicemail saying they found a solution, will see.
     
  12. buddd thread starter macrumors newbie

    Joined:
    Jul 5, 2011
    #12
    Solved! Solved!

    It was stupidly simple.
    I restored first all crap in Migration Assistant from TM backup, except for my profile.
    That worked and probably fixed something along the way.

    Then I ran MA again and restored only profile. So everything was restored!

    Interesting that Apple support said "it's known issues and it's impossible to transfer/restore profile from case insensitive fs to case sensitive". They were also very interested why the hell I needed case-sensitive OS.
    Hehe...

    Thanks everybody!
     
  13. indg macrumors 6502

    Joined:
    Feb 7, 2007
    #13
    i had a feeling it might have something to do with that case-sensitive file system. so your old mac didn't use case-sensitive fs? i'm still not convinced why you need it (never heard of anyone who would), but i figured you had your reasons. anyway glad everything worked out. hope it's smooth sailing from here on out.
     
  14. buddd thread starter macrumors newbie

    Joined:
    Jul 5, 2011
    #14
    Everything is ok after restore, except for one thing: freaking time machice doesn't allow backup on remote driver over afp.

    Aug 11 20:39:07 me mds[60]: ERROR: _MDSChannelInitForAFP: AFPSendSpotLightRPC failed -1

    I tried with the old volume, created new, used hdituil create and so on...

    Stupid time machice says: "You do not have the necessary read, write and append privileges on the selected network backup disk."

    But I guess this is another story :)
     
  15. ankh macrumors member

    Joined:
    Jan 9, 2003
    #15
    Maybe similar -- 2007 Mini to mid-2011 Mini via Ethernet.
    First 'migration assistant' pass didn't copy any documents or apps later than June 2011.
    A second pass seems to have worked.

    Oddity --- when I try copying files, I get an authentication warning that the copy can't be completed, but usually no option to authenticate. After that, I sometimes get the copies as expected; other times I get what appear to be files, correct icons, but zero size.

    Dunno.
     

Share This Page