Migration Assistant giving problems ... pull HD as workaround??

Discussion in 'MacBook Air' started by mojibake, May 13, 2008.

  1. mojibake macrumors newbie

    May 13, 2008
    So I finally finished cleaning out files on my old MB, installed the Air Migration Assistant and connected via Ethernet and followed all the steps, but it doesn't get very far before popping up a message with "connection problem" or something and then just hanging. Grr.

    Yes, I know, lots of people have this problem, and the workaround is to do a Time Machine or SuperDuper backup to a USB drive and migrate from there. But my old MB is a Tiger machine and I don't have a USB drive...

    Has anybody tried taking the hard drive out of the old MB, plugging it into a SATA-to-USB cable, and migrating directly from the hard drive?


    Sounds like this might be the fastest way to migrate data to a MB Air?

    (and by the way, what's up with there being no Create New Topic button on Apple Forums?)
  2. grimdonnn macrumors newbie

    Mar 28, 2008
    Austin, TX
    Why do you need to pull the HD?

    Just connect the two computers via the ethernet, log-in to the old computer via the "connect to Server" under "Go" in the finder, and the old HD shows up on the MBA. I do this all the time to transfer files.
  3. n0de macrumors 6502

    Feb 3, 2005
    Maybe a combo USB/Firewire drive enclosure, you can get a 3.5" drive one pretty cheap. Use the FW interface to Carbon Copy the old system then the USB connection for migration asst to get everything off.
  4. mojibake thread starter macrumors newbie

    May 13, 2008
    Because Ethernet doesn't work -- it fails with "connection problem" at random times during the migration. Of course, Apple Store staff just shrugged it off and told me that Migration Assistant hardly ever works -- mind you, this is with a bone stock brand new MacBook Air freshly installed and patched. Grr.

    Others have mentioned the idea of cloning the old drive to an external USB drive before, but I don't have a spare HFS-formattable USB drive and would like to avoid buying one just for this purpose.

    So anyway, I decided to try it -- pulled the drive out of the old MacBook and plugged it in to a SATA-USB cable, and drive mounted just fine. Oddly, though, the MacBook Air trackpad refused to work when the drive was plugged in -- as in, the motion became crazy jittery and only horizontal. Ooookay, so in goes the USB hub and the mouse to make it work. That worked okay until somewhere in the middle of migration the MacBook Air crashed hard and display went dark and nothing worked, not even caps lock -- only the CPU was busy heating up the planet. Grr. Okay, reinstall OS one more time....

    So I guess my trusty SATA-USB cable is somehow incompatible with the MacBook Air. Maybe I'll try taking apart my USB hard drive and swap the internal hard drive with the one from the MacBook and see what happens.

    Oh, and, when I plug the APPLE SUPERDRIVE into the MacBook Air, the same trackpad problems result. But after a couple minutes it slowly resolves.

    What the heck is wrong with this computer?? *Nothing* seems to work the way it should. Oh and by the way, this is after a logic board replacement last week.
  5. grimdonnn macrumors newbie

    Mar 28, 2008
    Austin, TX
    I think this is more a problem with Migration Assistant than the ethernet...

    I never even tried Migration Assistant, because my old laptop was running 10.2 and so the migration utility was not compatible with the air. I just connected via ethernet, logged in as I described, and manually downloaded all the files I wanted (mainly the documents folder and my itunes and iphoto libraries). It took several hours, but I never had an "ethernet disconnect". I also routinely connect to my desktop at work to transfer several Gb of files. Never a problem.

    I would still suggest you try this.

Share This Page