Migration Assistant - next step!

Discussion in 'Mac Basics and Help' started by Microwe, Jul 4, 2011.

  1. Microwe macrumors newbie

    Joined:
    May 9, 2007
    #1
    I have just successfully transferred my iTunes, iPhoto, documents folders etc from my trusty eMac G4 to my mid 09 13" MBP Intel. Before I go any further I would appreciate some advice on the next step as this is the first time I have done this.

    The transferred folders are now on the hard drive of my MBP in a folder with the name that I used as the Admin on my old Mac.

    I am unable to access anything in this folder as I get a message saying "The folder can not be opened because you don't have permission to see it's contents". I presume that I have to go into System Preferences>Accounts and log into the account that has just been transferred.

    Basically my question is how do I integrate the new folders with the existing ones and use just one account name. I have never used iTunes, iPhoto or Mail on my MBP. Do I have to get them setup first or will that happen when I find out how to migrate the old files into the system.

    Any advice would be truly appreciated.

    Michael.
     
  2. Microwe thread starter macrumors newbie

    Joined:
    May 9, 2007
    #2
    After searching for a considerable time I found the answer here under ..Transferring files from one account to another on the same Mac....http://support.apple.com/kb/HT3309.

    The final part of the instruction says "Copy any files or folders you wish from the Shared folder to the desired locations, such as desktop, Documents folder, Music folder, and so forth". Transferring files like iTunes, iPhoto Mail and Documents is straight forward as the folders on my MBP are empty.
    However, can some knowledgeable user advise me what I do in the case of the Library folder, or is it a matter of going through each folder and transferring data that is not already there?

    Michael.
     
  3. Microwe thread starter macrumors newbie

    Joined:
    May 9, 2007
    #3
    Before I shoot myself with frustration somebody please help. I followed the above instructions for transferring my files and folders to the Shared folder, only to find that when I then tried to copy them to my Admin account on my MBP I get the same message that I got at the beginning about not having permission to see the contents.

    I am obviously doing something really wrong. Can someone please point me in the right direction.

    Michael.
     
  4. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #4
    If you do the migration during Setup Assistant, i.e. before creating an account, you'll have only one account on the computer. If you do it after creating an account, you end up with two. Typically, unless you need anything from the temporary account you made before migrating, you log out out of it and into the migrated account, and delete the stand-in. Now, if you are trying to merge accounts, when deleting the one you no longer want to have as a login, choose to save it as a compressed disk image or keep the home folder. This will then allow direct access to the files from the remaining account without permissions issues.
     
  5. mp04, Jul 4, 2011
    Last edited: Jul 4, 2011

    mp04 macrumors newbie

    Joined:
    Jun 25, 2010
    #5
    If you dragged and dropped from your old g4 to new MBP (use Target mode or whatever... no really important how they got there) then try this...

    select folder and hit Command+I or File>get info
    go all the way to bottom "Share and Permissions" section, and see what it says next to you name...

    If it says no access... then click on the little pad lock on the bottom right and enter you username and password for your user account that you have right now (NOT username and password for any old account etc), and from there, you should be able to change you access level from "No Access" to "Read and Write".

    To speed up things, (if you noticed that enclosed items are also blocked" you can also click on the little gear with the drop down arrow, and select the "apple to all enclosed" option.

    Hope this helps.
     
  6. Microwe thread starter macrumors newbie

    Joined:
    May 9, 2007
    #6
    Thank you for the suggestion. I am now slowly getting there.

    Michael.
     
  7. RogerioAbaurre macrumors newbie

    Joined:
    Jul 18, 2012
    #7
    this solved the problem!
     

Share This Page