Migration Assistant Nightmare

Discussion in 'macOS' started by pondosinatra, Jul 20, 2015.

  1. pondosinatra macrumors 6502

    Joined:
    Jun 9, 2009
    Location:
    Calgary, Canada
    #1
    Trying to migrate my info from my old iMac running Snow Leopard, to my new iMac running Mavericks.

    - Both OS's fully updated, I applied the 1.1 Migration Assistant patch to the old Mac.
    - Firewall is turned off on both
    - Internet connection sharing is turned on for Ethernet on both
    - Both Macs plugged in with Ethernet to a shared switch (nothing else connected to switch) and each can ping the other
    - Start MA on the new Mac, start on old Mac and tell it transfer To another Mac and it searches. I select transfer From another Mac on the new one, it sees the old one, I click on it, continue, it gives me the passcode, but the old mac never gets it.
    - I briefly got it to work, by switching the Internet connection sharing to use Wifi and reran, and the old Mac got the passcode, but not wanting to transfer over Wifi I kept trying to get using Ethernet working. Here's the thing though, I went back and set everything the way it was when it briefly worked with Wifi, but now it also fails.
    - Firewire isn't an option as the new Mac only has Thunberbolt ports
    - Scoured the internet and see that no one can get the bloody thing to work

    Anyone managed to actually get MA to work transferring from SL to Mavericks using Ethernet?
     
  2. BrianBaughn macrumors 601

    BrianBaughn

    Joined:
    Feb 13, 2011
    Location:
    Baltimore, Maryland
    #2
    It would seem to me that you should turn Internet Sharing via Ethernet on for one computer only and connect the other directly via ethernet.
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    There is no need to have internet connection sharing turned on, so I would disable that.

    Then plug the ethernet cable in directly between the two machines and try again. There is no need to go through the switch.
     
  4. pondosinatra thread starter macrumors 6502

    Joined:
    Jun 9, 2009
    Location:
    Calgary, Canada
    #4
    My next step was to use a crossover (had to get one from work). But everything I read online said you had to enable Internet connection sharing. I'll try without it and post back.
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    Nope... you do not need to turn on sharing and no crossover is needed. All newer Macs do not require a crossover cable.
     
  6. pondosinatra thread starter macrumors 6502

    Joined:
    Jun 9, 2009
    Location:
    Calgary, Canada
    #6
    Got it. I did as Weaselboy suggested, but it still wouldn't work. Then I finally figured it out. There's a bug/feature in Mavericks that whenever you run MA it will turn on WiFI automatically (SL does NOT do this). As soon as the new Mac turned on WiFi the other Mac lost the ability to ping it (I would always turn off WiFi prior to running MA).

    Solution was for me to go into Network Preferences and forget my WiFi network. Reran with everything as was suggested (direct connect via regular ethernet cable, with Internet sharing turned off) and it worked!
     
  7. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #7
    Glad you got it sorted. I should have remembered to mention that to you, because I have seen it before.
     

Share This Page