Migration Assistant on new Mini won't recognize Time Machine drive

Discussion in 'Mac mini' started by Jaze, Nov 8, 2012.

  1. Jaze macrumors member

    Sep 5, 2001
    I'm wondering if any of you guys are having this problem.

    I'm just setting up my new Mac Mini. It's sitting there nice and purty, with my external Time Machine drive that I've been using on my old iMac sitting there on the desktop labeled "Time Machine Backups", plus my two other external hard drives.

    I want to back up onto my new machine from a recent back up. I go to Migration Assistant, kick it into gear, but the only drive that it sees is the Mac Mini hard drive (a 1TB Fusion drive, don't know if that makes a difference); it doesn't seem to see the Time Machine drive, or the other two external hard drives I have mounted there. How can I get it to do the right thing here, and import all that stuff from my Time Machine backup?

    Thanks in advance for any suggestions.

  2. StevenT42 macrumors 6502

    Jun 9, 2010
    Plug the Time Machine drive directly into the Mac mini, not into your iMac.
  3. Jaze thread starter macrumors member

    Sep 5, 2001
    Can't tell if you're joking there.

    To be clear, the Time Machine is plugged directly into the Mini, and is mounted on the desktop; it just doesn't show up as a source option when I run Migration Assistant.
  4. StevenT42 macrumors 6502

    Jun 9, 2010
  5. Mojo1 macrumors 65816

    Jul 26, 2011
    I had a similar problem when I connected my new Mini to a 13" MacBook Pro. I selected the option to move data from another Mac but the MBP was not found by Migration Assistant. But when I selected the option to transfer data from a hard drive the MBP became available. (I may not remember the exact terms used for the MA options.)

    I suggest selecting another option even if it doesn't make much sense and see if your Time Machine drive shows up...
  6. Jaze thread starter macrumors member

    Sep 5, 2001
    Thanks, Mojo1. I tried that, no success.

    Tried quitting out of and reopening Migration Assistant several times, to no avail. But one thing I did notice: when I ran Migration Assistant, the first thing that happens is that the Finder quits (not only do the hard drive icons disappear from the desktop, but the Finder disappears as an option in the Force Quit window. I have no idea whether or not that means anything.

    This is frustrating. I WANT to have all that stuff back on this desktop, and to refill my iTunes and iPhoto libraries, and I want to do that before I start installing software.
  7. StevenT42 macrumors 6502

    Jun 9, 2010
    Time to call Apple. You have 90 days of free phone support.
  8. Jaze thread starter macrumors member

    Sep 5, 2001

    I have a nagging feeling I've seen something similar to this problem discussed here, and was hoping 1. that I'm right and 2. that someone would jump in with a definitive answer. I have a feeling it's something small and specific, possibly related to the Fusion drive.
  9. StevenT42 macrumors 6502

    Jun 9, 2010
    As a point of reference, I had problems running Migration Assistant with my Fusion Drive. This was during the initial logon, where you enter your language and wifi password. At that point, it asks if you want to transfer your files, in effect, run Migration Assistant. I did. But after an hour of transferring files, nothing showed up on the Fusion Drive. When I got logged back in and ran Migration Assistant manually, it worked. This was using my latest backup from a 2010 Mac mini on a USB 3.0 portable drive.

    If all else fails, you can run either Ethernet or FireWire between your iMac and Mac mini and transfer files that way. No backup involved, transfer directly from the iMac.
  10. hfg macrumors 68040


    Dec 1, 2006
    Cedar Rapids, IA. USA
    Can you open the Time Machine icon and see the files in finder?

    Is your Time Machine backup encrypted?

    What is your backup drive and how is it connected to your Mini? How about the other external drives?
  11. kdoug macrumors 6502a


    Jun 2, 2010
    Iowa City, IA USA
    That happened to me this evening when I was setting in a new Mini. It would recognize my USB 3.0 flash drive with 10.8.2 installed but not time machine. I think I know the reason though. I dissacociated the time machine drive from my original computer. There is a way around it to make it work though.
    Restart your computer and hold down the "option" key and get to your hidden partition. If your partitions gone it'll boot to the Internet utilities. Once there, find restore with time machine and let it find your drive, it did mine.
  12. Jaze thread starter macrumors member

    Sep 5, 2001
    KDoug, I shall try that! Problem is I'm using a wireless keyboard and mouse, and am still trying to sort out how the damn things work!

    I'll report back.

    Thanks to all of you for your help, very much appreciated.
  13. mwhities macrumors 6502a

    Jul 13, 2011
    Your wireless keyboard will work exactly like a wired keyboard for booting options.
  14. Jaze thread starter macrumors member

    Sep 5, 2001
    Indeed it is - alas, no rebooting to the "Restore from Time Machine" option.
  15. xlii macrumors 68000


    Sep 19, 2006
    Millis, Massachusetts
  16. Jaze thread starter macrumors member

    Sep 5, 2001
    Figured it out. After trying all of these suggestions, unplugging, replugging, rerouting, etc etc, I have located the problem: the problem was Me. Migration Assistant was working just fine, but it was showing me the iMac Time Machine backup file by an unfamiliar numerical Hard Drive name, which I thought was the HD from my Mini, but turns out to be the HD from my iMac.

    Thanks, all! I hope that all your efforts are at least somewhat balanced by the pleasure of witnessing what a moron I am...

Share This Page