Migration Assistant Problems

Discussion in 'MacBook Pro' started by klib, Apr 5, 2014.

  1. klib, Apr 5, 2014
    Last edited: Apr 5, 2014

    klib macrumors newbie

    Joined:
    Apr 5, 2014
    #1
    Hey there,

    We are attempting to use Migration Assistant to move data between an old Macbook Pro (Intel Core 2 Duo) to a new Macbook Pro Retina (Core i7) with absolutely zero luck.

    We have updated the OS's on both laptops to latest (10.9.2)
    We have done the disk permission repair
    We have ensured even the version of Migration Assistant is the same

    Not luck at all.

    We are attempting to do this via the network (Ethernet connection) and the two laptops see each other fine and get up to the step where you select what files you want to copy and then you are prompted to confirmed whether you want to overwrite the user account on the target (because they are the same) and then what happens is Migration Assisant crashes on the Source machine and you are returned to the log in window.

    I have had a quick look in the console and can see the crash but I am unable to work out what it all means - the crash reports/logs dont seem to mention anything in particular (or that I can userstand)

    Does anyone have any tips here on how we can get this to work over the network (I have read a few threads which say that ethernet is not possible, but surely in 2014 this is not true). Unfortunately the source laptop does not have a thunderbolt port so we can not use a thunderbolt cable and having to go and spend money on a thunderbolt to firewire adapter seems like a waste given that it should surely work over the local network.

    We have also tried direct connect via network cable (laptop to laptop not via the switch) this starts the copying then crashes
    We have also tried booting in to safe mode and then running the apps but the laptops wouldnt even find each other.

    In short - attempting to use Migration Assistant over the local network. Laptops see each other but source laptop crashes and we are returned to login screen.

    Any help appreciated.
     
  2. Ravenis macrumors member

    Joined:
    Feb 4, 2014
    #2
    If possible as a workaround try doing it via time machine

    If not, try migrating just the user or just the applications, see if you can isolate it down.
     
  3. Markovich macrumors member

    Joined:
    Jul 22, 2008
    Location:
    Central Ohio
    #3
    I had the same issue last weekend when I picked up a new 13" MBPr and used MA with my 2009 MBP via a ethernet connection.

    I used the Thunderbolt-ethernet adapter on the new MBPr and connected to the ethernet port on the 2009 MBP.

    MA bombed frequently , or the session timed out.

    Here is what I did:
    Turned off Wifi on both MBPs
    Set Energy settings on both to Never go to Sleep
    Restarted MA and forgot about the process. Came back an hour later and it was almost done.
    Way too complicated for Apple.
     
  4. klib thread starter macrumors newbie

    Joined:
    Apr 5, 2014
    #4
    Thanks for the reply.

    I have tried just doing applications and that failed (crashed on source and sent me back to log in screen).

    I have attempted to just do documents and data but that crashes the source machine before I even click on continue.

    In regards to the time machine work around - I have run a time machine back up and with the output saving to an external hdd but when I plug this into the new laptop and run Migration Assistant it sits looking for sources for 30 mins (forgot about it for a while) and never picks up the external as a source.

    Any other thoughts?
     
  5. Ravenis macrumors member

    Joined:
    Feb 4, 2014
    #5
    With the external hdd plugged in on the 'looking for other sources' window you don't see anything at all above it? Does it mount on the desktop even?
     
  6. klib thread starter macrumors newbie

    Joined:
    Apr 5, 2014
    #6
    Just had another look at the external is not mounting.

    Not sure what is going on here, it mounts and is visible (and useable) on my iMac (i5 non retina) however the new macbook does not see it.

    We managed to get Migration Assistant to work when selecting only Applications from the iMac to the Macbook, but now we are attempting to do documents and the target macbook is now failing and crashing back to the login screen.

    The strangeness continues.....

    Thinking of doing a clean install on the Macbook (a reset to factory settings sort of thing) but given I am not a Mac person I am concernred by some of the threads I have read about that being complicated and potentially causing issues as well - one thread suggested booting in repair mode and then erasing Mac HD and then reinstalling the OS, is it as simple as that or are there other issues to be careful of?
     
  7. klib thread starter macrumors newbie

    Joined:
    Apr 5, 2014
    #7
    Just seen your post - it sounds like you are getting further through the process than I am in that I am dead in the water (crashed and sent to login page before I can even click continue after selecting what to migrate, or immediately after).

    Interestingly the external that I used for the time machine backup seems lost to the new mac book for ever now. I works on the old mac book and the new imac but the new macbook just doesnt see it. Getting quite frustrating to be fair.

    If rebuilds are not too much of a problem then that might be the shot here,clean start and only try migrating applications off the new imac - although the idea was to migrate all the mail account settings and emails themselves via this app.
     
  8. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #8
    Let's back up. Even if you get this to work you are going to have no end of problems importing the user account into an already existing user account on the new machine (if I am understanding what you did).

    Login to the account on the Retina and make a new temp admin account then logout of your account and login to the temp account. Now from the temp account delete your account. So now all you have is the temp account and you are logged in to temp. Now run Migration Assistant from the temp account.

    Make sure wifi is off on both machines as mentioned earlier.

    How are you connecting the Retina to ethernet?

    If you have a good Time Machine backup from the old Mac, that would be faster than ethernet if you can get it to work.

    Just check all the boxes in Migration Assistant and let it replace whatever you did before.
     
  9. Ravenis macrumors member

    Joined:
    Feb 4, 2014
    #9
    Sounds like you have corrupted data, its failing with migrating the user account from what you say here.

    I would just manually drag/drop from this point, move on from migration assistant.


    If you are keen on getting the user account then you can drag the home folder to the external drive then follow the steps here to manually recreate it:

    http://hints.macworld.com/article.php?story=20110328151104860
     

Share This Page