Mikey

Discussion in 'MacBook' started by mossypointman, Jun 26, 2011.

  1. mossypointman macrumors newbie

    Joined:
    Jun 26, 2011
    #1
    Replaced HD in MB Black Dual core2 with WD Scorpio Black 750GB, 7200rpm. Disk utility thinks it is a 5.5TB HDD ??? Partition won't work - I/O error reported. Used a second MB with a USB HD dock to partition the WD and it worked. reinstalled in Black MB and found OSX install gives error - "cannot install on this disk" Any ideas???:(
     
  2. Bear macrumors G3

    Joined:
    Jul 23, 2002
    Location:
    Sol III - Terra
    #2
    When you formatted the drive, what type of partition table did you use? Intel based Macs require a GUID partition table to be able to boot off of a disk.
     
  3. mossypointman, Jun 27, 2011
    Last edited: Jun 28, 2011

    mossypointman thread starter macrumors newbie

    Joined:
    Jun 26, 2011
    #3
    Mikey

    Thanks Bear, Yes I set up a GUID partition.
    Update: I set the WD 750GB drive in a USB dock and connected to another MB, I then used CCC to copy its HD to the WD. That worked OK, in fact I found that I could now boot from the WD via the dock and that Disk Utility now correctly recognised the WD as a 750GB disk. However, when I reinstalled the WD internally in the MB it refused to boot. I tried to boot from the OS X install DVD but that wouldn't work either.

    Good news - The WD 750GB HD is now bootable and is working well. I connected the 2 MB's via Firewire and used Disk Utility to reformat the WD, (one odd thing the partition table was showing as an Apple table?) I reset it to GUID and everything worked from there.
     

Share This Page