Minecraft not working after Snow Leopard upgrade

Discussion in 'Mac Basics and Help' started by Sterlingholobyt, Sep 20, 2014.

  1. Sterlingholobyt macrumors newbie

    Sterlingholobyt

    Joined:
    Nov 9, 2013
    #1
    Hello,
    I have just upgraded my iMac to Snow Leopard 10.6.3 from 10.5.8(I know, I am a little late to the game, but I have never needed to upgrade until now), and now I get an error when launching Minecraft. Has anyone else had this problem and do you have any advice on what to do to fix this?

    Here is the error I am getting. I get to the "Play" screen, and if I press it it loads for a little bit, but then gives me this message:

    Exception in thread "main" java.lang.UnsatisfiedLinkError: /Users/Blaschke/Library/Application Support/minecraft/versions/1.8/1.8-natives-1411238153797787000/liblwjgl.dylib: Library not loaded: @rpath/libjawt.dylib Referenced from: /Users/Blaschke/Library/Application Support/minecraft/versions/1.8/1.8-natives-1411238153797787000/liblwjgl.dylib Reason: image not found
    at java.lang.ClassLoader$NativeLibrary.load(Native Method)
    at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1861)
    at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1785)
    at java.lang.Runtime.loadLibrary0(Runtime.java:823)
    at java.lang.System.loadLibrary(System.java:1045)
    at org.lwjgl.Sys$1.run(Sys.java:73)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.lwjgl.Sys.doLoadLibrary(Sys.java:66)
    at org.lwjgl.Sys.loadLibrary(Sys.java:95)
    at org.lwjgl.Sys.<clinit>(Sys.java:112)
    at bsu.I(SourceFile:2462)
    at net.minecraft.client.main.Main.main(SourceFile:40)

    Thank you for any help!
     
  2. vmachiel macrumors 68000

    Joined:
    Feb 15, 2011
    Location:
    Holland
    #2
    Maybe reinstall 1.8 again (delete the jar from your minecraft folder (under versions) and it will donwload again. Make sure your Java is up te date as well.
     
  3. Sterlingholobyt thread starter macrumors newbie

    Sterlingholobyt

    Joined:
    Nov 9, 2013
    #3
    Thank you for replying, VMachiel!

    I never did find out what was the matter with it, but I upgraded from Snow Leopard to Mavericks, since it was a free upgrade, and that seemed to do the trick. Don't know why. But Minecraft works again so all is good. Thanks again!
     

Share This Page