Mini and Firefox Performance

Discussion in 'Mac mini' started by Jackintosh, Oct 3, 2009.

  1. Jackintosh macrumors 6502a

    Jackintosh

    Joined:
    Mar 21, 2009
    Location:
    Illinois
    #1
    Apologies that this may not be the right forum, but many Mac/Firefox users may not see this otherwise. Wanted to share.

    Ever since getting my new latest generation Mini, I've had a devil of a time with painfully slow loading pages and long waits. Finally fixed all that with some tips and tweaks that everyone might want to consider. All this did wonders for me:

    1) Switch default DNS settings to OpenDNS:
    https://www.opendns.com/start/

    2) Turn off IPv6 in System Preferences:
    Network, Advanced, TCPIP. Configure: IPv6=off

    3) Disable IPv6 in Firefox:
    about:config
    network.dns.disableIPv6=true

    4) Tune Firefox:

    http://www.wikihow.com/Make-Firefox-Load-Pages-Faster

    1. Type "about:config" into the address bar and hit return. Scroll down and look for the following entries:
    network.http.pipelining,
    network.http.proxy.pipelining,
    network.http.pipelining.maxrequests
    2. Normally the browser will make one request to a web page at a time. When you enable pipelining it will make several at once, which really speeds up page loading.
    3. Alter the entries as follows:
    4. Set "network.http.proxy.pipelining" to "true" by double-clicking it.
    5. Set "network.http.pipelining.maxrequests" to 8 by double-clicking it. This means it will make 8 requests at once. There is no point setting it higher then 8 as it is capped at 8 max. [The default value for this setting is 4]
    6. Lastly right-click anywhere and select New-> Integer. Name it "nglayout.initialpaint.delay" and set its value to "0". This value is the amount of time the browser waits before it acts on information it receives.
    7. If you're using a broadband connection you'll load pages MUCH faster now!
     
  2. Krafty macrumors 601

    Krafty

    Joined:
    Dec 31, 2007
    Location:
    La La Land
    #2
    Then problem I'm having is that sometimes when typing, FF will freeze for a few seconds, and the spinning beachball of hell comes up for a split second and then returns to normal. Sometimes it doesnt.
     
  3. Jackintosh thread starter macrumors 6502a

    Jackintosh

    Joined:
    Mar 21, 2009
    Location:
    Illinois
    #3
    Typically beachball means swapping data in/out, meaning not quite enough memory. How much memory do you have?
     

Share This Page