mini refuses to sleep on

Discussion in 'Mac mini' started by dilnad, Feb 5, 2007.

  1. dilnad macrumors newbie

    Feb 5, 2007
    Uhh, subject should read "mini refuses to sleep on its own." ;)

    First time poster, hope someone can help! I've got something I can't seem to figure out going on with this mini (1.24 GHz/40GB/512 MB/Panther 10.3.9. The last time it actually went to sleep on its own must have been well over a year now.

    At first, I thought it was things I had running - WeathermanX in the dock, OS X VNC server, and I had some NFS exports going to my Linux box (/Users shared, as was my firewire LaCie drive but also running an NFS server on the Linux box, had a couple of its partitions mounted on the Mac.) Had some items under sharing enabled, such as Remote Login so I can ssh into the mac. However, I found that killing anything extra that was running, getting rid of my NFS shares, and disabling things such as remote login, it still wouldn't sleep on its own. It sleeps just fine if I tell it to either by the menu or power button.

    I finally got around to doing a clean install, but after I installed everything and had it set up similar to what it was previously, it still did not go to sleep on its own. That's when I decided to nuke it again and start over, setting the sleep interval to 1 minute and trying one thing at a time until I made it no longer go to sleep.

    I went to bed while it was installing, and this morning it was asleep. I woke it up, it was at the later stages of install where it needed my input. Once the install was complete, I set it to sleep after a minute and it did. Used Safari for a bit, didn't install anything else, then went off to work. It was sleeping this evening when I came back home. I then was looking for some weather stuff, thought maybe WeathermanX may have been keeping it from sleeping, so I tried weather dock. I started it up, looked at it for a minute then closed it out. Of course now, it is not sleeping. Deleted weather dock, rebooted, still no sleepy! If I tell it to sleep, it sleeps.

    I'm booting up with absolutely nothing running, the only settings I've changed were for the resolution and sleep time, that's it. It's still pretty much in its post-clean-install state, still won't sleep. Unless I make it. I'm not sure what I've done to break the previously sleeping install this time. Don't understand why it would work then just quit. *shrug*

    Anybody have any ideas on this one?

  2. karichelle macrumors member


    May 26, 2006
    Small update to progress on this problem, from "dilnad's" fiancee... ;)

    It will sleep on its own when it has a CD in the drive, but not when it doesn't. Any ideas why this might be? Seems very strange.

    Any assistance would certainly be appreciated! :)
  3. macgeek77 macrumors regular

    May 24, 2006
    This is tough because i don't know if its a hardware or software issue. From reading you description, it sounds much more likly to be a software issue. I would check and see if this software you are using has any patches or reports of this happening. Perhaps it can be updated. Moreover, try zapping the PRAM and resetting your firmware for good measure. Hope this helps.
  4. karichelle macrumors member


    May 26, 2006
    That's just the thing -- it doesn't seem to be a software issue unless the issue is with OS X itself, because it's refusing to sleep on the bare bones system with nothing installed that didn't come off of the restore disk. And it's also been done with two different restore discs, so there's no error there either. It's very mysterious and frustrating. It's set to go to sleep after 1 minute, but sometimes after 30 minutes or more have passed it will suddenly go to sleep, almost as if it's waiting on something, but what, we have no idea, since it has nothing installed except OS X and iLife and all of the stuff that came on it in the first place.

    He's also zapped the PRAM a few times to no avail. :(
  5. CptnJustc macrumors 6502

    Jan 19, 2007
    I had this problem recently. In my case I narrowed it down to the VNC server (not only would it not sleep, it wouldn't even let the display sleep). It seemed that on rare occasion, the VNC server would still think there was something attached to it, even though I'd shut my client. You can check by the menu bar icon, if you have that enabled. Shutting down and restarting the VNC server (I'm just using the built-in one) did the trick.

    Stuff that accesses the network or has the network access it can reset the sleep timer, and can be the hardest stuff to track down. But I don't think drive shares or remote login (assuming nobody's connected or accessing the drives) affects it.

Share This Page