Mini-Toslink not sending audio.

Discussion in 'MacBook' started by AWallen90, May 16, 2011.

  1. AWallen90 macrumors 6502

    Joined:
    Sep 15, 2009
    #1
    Late '06 Macbook C2D 2.0 2GB ram.

    Had two of these kept this one because the headphone jack works perfectly for plugging in a 3.5mm plug. My other Macbook the jack was worn out, but the toslink worked great.

    The Toslink on my current macbook does not seem to send any audio to my stereo. I have a beam of light I have checked all the settings that I know to check. My receiver is in perfect working order, the port works and the cable is undamaged as I have tried it on other devices. The macbook is telling me the optical output is selected.

    Short version: Light but no sound from toslink?

    Suggestions?
     
  2. AWallen90 thread starter macrumors 6502

    Joined:
    Sep 15, 2009
    #2
    Anyone else have this problem? Does anyone even use optical?
     
  3. JaSuS macrumors regular

    JaSuS

    Joined:
    Jul 22, 2010
    Location:
    127.0.0.1
    #3
    I am no help but I just realized that there is a light in my headphone jack for the macbook...turns out it's optical :)
     
  4. AWallen90 thread starter macrumors 6502

    Joined:
    Sep 15, 2009
    #4
    I was pretty ecstatic the first time I was looking at a numbered diagram and saw that it was analog/digital.
     
  5. JaSuS macrumors regular

    JaSuS

    Joined:
    Jul 22, 2010
    Location:
    127.0.0.1
    #5
    hmm....someone with more knowledge would come along :)
     

Share This Page